0 Favourites

How do I support IE9

  • Hello ,

    I have a bug in my game with IE9. When I start the game the screen keeps black and in console I get following errors:

    LOG: Assertion failed: JS engine does not provide full typed array support 
    
    SCRIPT5022: abort() at (no stack trace available)
    If this abort() is unexpected, build with -s ASSERTIONS=1 which can give more information. 
    c2runtime.js, line 22056 character 15
    
    SCRIPT438: Object doesn't support property or method 'getObjectRefTable' 
    c2runtime.js, line 3917 character 3
    [/code:szcp84h9]
    I hope someone can help me.
    
    Greets,
    Simon
  • Well, I'm saying something that's obvious, but Internet Explorer is a browser that you might want to skip. Simply because it's not safe nor complete like most of other browsers and has some issues with HTML5 games.

    Maybe it's better if you could just focus in other browsers like Chrome and Firefox.

  • For me it would be no problem to avoid Internet Explorer. But our customer only works with IE9, so I have no other chance.

  • For me it would be no problem to avoid Internet Explorer. But our customer only works with IE9, so I have no other chance.

    I understand your case.

    Well, as far I was looking for a solution, one way to solve this is to make a compatibility with older IE's version (like IE8).

    Something like:

    meta http-equiv="X-UA-Compatible" content="IE=8" />   [/code:qykqwuf6]
    But it may need some advanced editing in the file, I'm not sure if there's a way to do this in Construct 2.
    
    Also, I found a page to show you, but this stupid reputation system doesn't allow me to post any link. It says you and your client should Turn off the Default Compatibility View in IE9. In the Compatibility View settings, disable the checkbox “Display all websites in Compatibility View”.
  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Unfortunately IE9 lack many of the necessary features needed to support HTML5 games. I might be wrong about this but IE9 will probably never be able to run games made in C2 reliably.

    Unless Microsoft moves IE to a rapid release cycle it will always be an outdated browser. IE9 is 4 years old now, which is ancient for a browser. Your customer needs to understand this if they wish to use modern web apps.

  • Ok, so there is no fix which make it possible to play the game in IE9?

  • Ok, so there is no fix which make it possible to play the game in IE9?

    Why don't you explain this for your client and suggest him to use another browser? As ryanrybot Microsoft isn't fast and focused to improve Internet Explorer as they like to say in every new version.

    But if (s)he is a Microsoft-fan to refuse alternatives, you should convince the client to either to upgrade to latest IE version and/or turn the Default Compatibility View off.

  • There are already two newer versions of internet explorer, called IE10 and IE11 and in two months Microsoft will introduce windows10 with yet another browser

    Why would your client stick to a webbrowser that is so outdated?

  • Ok, I find out where the problem was.

    I deleted the sound files and all Audio inculcate now the game works in IE9.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
99 10,136
karshinkoff's avatar
karshinkoff
Unread hot topic
107 11,510
tgraupmann's avatar
tgraupmann
Unread hot topic
82 7,346
Ashley's avatar
Ashley Construct Team Founder