0 Favourites

COMPLETELY INTRIGUED...

  • I am completely intrigued by the fact that I try to position a sprite on LAYOUT, place it exactly where I want and when I preview it on browser it will simply not be where I had placed on Construct 2 LAYOUT VIEW.

    Not only that, like a magnet even if I try to move it pixel by pixel it will either be way above or below I wanted it.

    I am previewing on Chrome and LETTERBOX SCALE. Is this the best normal scaling method before creating project on XDK to generate APK???????????

    help!!!

  • Are You using different layers with parallax setting?

    Are you checking the dotted line in layout editor. That's the window size. What you would see on screen, are you setting that in code? Or do you use some special letterboxing setting?

  • Like tunepunk says, the default C2 project starts with 500,500 margins which -- in my experience -- you always want to set to 0,0 to make the sprites appear in the proper places.

  • Are You using different layers with parallax setting?

    Are you checking the dotted line in layout editor. That's the window size. What you would see on screen, are you setting that in code? Or do you use some special letterboxing setting?

    Thank you. I will try that.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Like tunepunk says, the default C2 project starts with 500,500 margins which -- in my experience -- you always want to set to 0,0 to make the sprites appear in the proper places.

    Thank you. I will try that.

  • Just an idea

    If you are positioning it in the layout

    but it is moving in your game

    then maybe it is an animated sprite? (or you have more than one frame by mistake)

    and for the last frame you are stopping on, the origin point is in a different place than in first frame?

    This will cause it to move place in game.

    (as you position in layout from origin point of first frame then it moves to the origin of the last frame in game)

  • Sorry guys... I had a SYSTEM CREATE OBJECT AT XXX,YYY AND THAT WAS THE PROBLEM

    Fell ridiculous.

    I am sorry.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)