0 Favourites

Collisions not always detected during attack event

  • Hey guys,

    im having trouble getting two objects to collide (or at least for it to detect it) when requesting it only detect during certain frames of an animation

    ive got a main sprite who swings a chainsaw and an invisible collision box

    the collisions have been working up untill i added the condition for it to detect it during the animation and only on the certain frames

    heres the events for the collisions (works if i disable the two sub conditions, but it just kills them all the time whenever it touches)

    imgur.com/RuDUGAb.png

    and heres the sprite with his collision

    imgur.com/uwHakiM.png

    cant post images, too new, sorry!

    *quick edit*

    i can always upload the file for soemone to look at if prefered, but id rather be shown how to fix it, than just have it fixed for me, so i can learn :)

  • The thing is that it's hard to show you how to fix it without being able to see what the problem is in the capx. :)

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • yeah i was hoping i wouldnt have to upload, then i realised i could just throw it into my public dropbox

    ask and ye shall recieve! even though you didnt ask.. xP

    dl.dropboxusercontent.com/u/2150354/Zombie%20Panic.capx

    hopefully this helps

  • i got it working!

    i read somewhere events are read from top to bottom, a little tweaking of the conditions made it read and act better so it works

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
378 33,278
part12studios's avatar
part12studios
Unread hot topic Locked topic
115 17,217
Kyatric's avatar
Kyatric Construct Team Support
Unread sticky
83 102,312
gamearcad's avatar
gamearcad