0 Favourites

localhost issues - loads fine on other game but new one not

  • My son has been learning Construct 2 via Zenva Academy but the localhost has become a real issue on new layout. Last game (Jumping Sally) he made loads no problem but current one (Crazy Escape) only loads sometimes, like 1 out of 10 times - I'm trying F4, F5, the small run layout key and the larger one in the ribbon.

    I tried changing the port, browser, etc. but all don't seem to have much effect. I've updated my display drivers, java, the system as a whole, running out of things to try. This is on a Windows 10 laptop. The main RUN LAYOUT tab work only sometimes vs button at top corner vs F4. Very frustrated here.

  • Try this.

    Add keyboard.

    On key pressed (choose a key)

    ______ Action > Local Storage > Clear storage

    Keep that event as long as you are developing the game.

    Now. Run the game. Press the key. Quit browser. Try again.

    Tell me if it works fine now.

    Do this every time that you 'messed' with the local storage. Or when you want the game to start with a fresh local storage during development.

    Hope this helped.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Didn't have local storage object created yet on this project but added it to test your tip. Wasn't exactly sure if it mattered where I placed the event so I placed it at the very top just below the global variables. Clicked the Run the Layout button and pressed the key I selected to Clear storage but not having any effect, still getting black screen or Construct 2 logo black screen.

    Let me know if I need to make an adjustment.

  • Good evening.

    It may be that some object is stopping loading (Object size), very large sprites can cause a very time consuming loading, since (HTML 5) loads all sprites before starting the games.

  • CTRL+F5 forces a hard refresh as well, you can try that. But it sounds more like something on that layout is causing an issue.

  • Gosh that darn dyslexia sometimes. I read Local Storage in stead of localhost, apologise.

    Plz share the project.

  • What's the best way for me to share the project here? Screenshot? I don't see a way to post attachments here.

  • I'm on a Windows 10 PC, been reading a lot about Ipv4 vs Ipv6 issues with localhost on this OS. I'm also on the Free version of Construct 2 so not sure if that has anything to do with this issue but yes I think it could be the layout causing issues too, just can't figure out what the system is hanging up on.

    My son isn't done with the project yet either, still a little bit to add. Really want to get this sorted out because he has another tutorial series he's going to do with it through Zenva Academy.

  • What's the best way for me to share the project here? Screenshot? I don't see a way to post attachments here.

    You'll have to upload the .capx file to a 3rd party storage (for ex. Dropbox, Google Drive) and copy the link here without the part since the forum won't let you post links because your account is new.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)