0 Favourites

Android API settings

  • Hi mobile Devs,

    I am in the alpha testing with my app now, but even now I would like to set up the minimum Android API to 19 so the minimum required Android version be 4.4 KitKat.

    1. I set it up in C2 while exporting to Cordova (I don't think this one does matter but anyway).

    2. I set up min api to 19 in Intel XDK settings (and 21 as target api)

    On my app page on Google Play it says the requirements are 4.0+ (!?).

    I've checked Intel XDK config files manually, and in one config file (can't remember which now) the minimum api was set to 14 (which is Android 4.0). The rest of files were set to 19 (there are 3 config files regarding crosswalk I think).

    I've edited the file and set it manually to 19. Built, sent to Google Play. And it is still required 4.0.

    Anyone else compiled mobile app with IntelXDK recently? Is it my problem only or something is wrong somewhere? I can't find anything regarding this issue on Google :/

    ps. I have the newest IntelXDK and C2.

  • I am surprised noone else is experiencing this issue. I believe noone have their app in alpha/beta testing atm.

    As I don't think this is a C2 issue but IntelXDK's (or Google's?) I have posted that on IntelXDK forum as well

    imaffett could you say if it's a known or unknown issue?

    I've googled that simillar issue was a Google issue last year. When app was in alpha/beta stage, Google was showing minimum required Android version as 1.6 instead of any other which was set in manifest file. But in my case it's showing 4.0, not 1.6 so or it's a different issue or it's a new face of an old issue. However I am not able (am I?) to check what is being send to Google Play after IntelXDK wrap C2 and IntelXDK config files to an APK.

    As I'm not an expert in IntelXDK config files, I'll show what's inside of mines.

    config.xml

    intelxdk.config.crosswalk.xml

    intelxdk.config.crosswalk.app.xml

    Is there any other place I should check as well?

    And here is what Google says about the app requirements.

    It is a critical issue for me. Any help is much appreciated!

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I have decompiled an APK file to check what's in the config.xml which has been compiled to the APK and it looks allright "<preference name="android-minSdkVersion" value="19" />". So it clearly a Google bug I believe.

  • Ok. I've found the cause. It's not Google, it's Intel bug.

  • Intel just fixed this issue. minSdkVersion is now honored.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)