0 Favourites

WACK Problems

  • Hi again,

    No capx the game runs OK.

    Not sure if this is bug or....

    This is a follow on to Closed bug Win8 App - WACK Fails.

    With the UTF-8 encoding now fixed in latest release of C2, the WACK passes from within VS - Thanks for the quick fix Ashley.

    But when you test the app using WACK outside of VS it fails the performance section. This is what the report states:

    Performance test

    FAILED

    Bytecode generation

    ?

    Error Found: The bytecode generation test detected the following errors: ?This package was deployed for development or authoring mode. Uninstall the package and re-install it normally.

    ?

    Impact if not fixed: As a performance optimization to accelerate JavaScript execution time, JavaScript files ending in the ".js" extension generate bytecode when the app is deployed. This optimization significantly improves start-up and ongoing execution times for JavaScript.

    ?

    How to fix: You may need consider one or more of these steps to fix the issue:

    • Ensure that event logging is enabled
    • All JavaScript files are syntactically valid; otherwise exclude the respective files from the package
    • Please note that you should uninstall all previous versions of the app before deploying

    Otherwise exclude the respective files from the package.

    As far as I know, while there are a few ways to deploy an app they all lead to the same resulting installation.

    I would rather not wait for a week only to find that the app fails certification on MS side.

    Weird that it passes WACK from within VS but not when running WACK outside of it - as far as I can tell it is the same process.

    Is there something I am missing?

    Should I submit the app to the store for certification?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Sorted, not a bug just a learning curve.

    For the benefit of others that may find this useful:

    To test your app you need to create a package for local distribution.

    Then install the package using PowerShell.

    Heres how:

    In VS:

          select Project\Store\Create App Package (Express: Store\Create App Package)

          In the Create Your Packages dialog choose the No option

          Select next and choose an output folder and create the package.

          In the output folder right-click the file Add-AppDevPackage

          This will install the app on your machine

          You will find your app tile on the Start screen

    You can run WACK from outside VS, select your app in the list, and test it...

    Note this can only be done on a machine that has a developer licence.

    This also appears to be the correct way to deploy your apps on your local\dev machine as opposed to deploying it from within VS itself.

    Hope this helps others.....

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)