0 Favourites

Text Problems in Chrome 35+ (NW 10)

  • Problem Description

    I know NW 10 is only an RC yet, but still, it seems the text object in general needs an overhaul.

    Since not only this problem, seems to be one (Performance problem on mobiles).

    But now to the problem, the problem persists since Chromium 35+ that means Node-Webkit 10 (RC1) too.

    When the text in the text object changes, it either disappears/get invisible or get's "Blocky"

    Example further down.

    Note: The problem only exists when using WebGL renderer

    As EpicPixel already noted, the problems only exists when using WebGL.

    When using Canvas2D the problems are non-existent.

    [quote:tzh4ao5i]it seems the problem only occurs with webgl, not with canvas2d

    Description of Capx

    Launch it with either chrome or the most recent NW (10 RC1) with WebGL renderer, see the text being "Blocky" or maybe disappearing.

    Launch it then with Canvas2D and see that there is no problem whatsoever.

    A random btw note: The freezing problem in Node-Webkit can be resolved by adding the chromium argument: "--disable-threaded-compositing" as fluffrabbit noted.

    So yes, it really fixes it. Already added it to my json file in the exporter folder in C2 Please make that change for r174 (If not Roger fixes this in general).

    Steps to Reproduce Bug and use the Capx

    • Launch it with either Chrome 35+ or NW 10 Using WebGL
    • Watch the text being buggy.

    Observed Result

    This happens:

    Or it get's invisible, sadly i couldn't reproduce that.

    Expected Result

    It should appear like this:

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (NO)
    • Internet Explorer: (NO IDEA)

    Operating System and Service Pack

    Windows 8.1 64bit

    Construct 2 Version ID

    R173

  • It must be a bug in node-webkit, not Construct 2. The next beta will ship with nw-0.10.0-rc1 and reproduces this, but it's up to the node-webkit developers to fix it, so I'd recommend filing a bug with them.

  • Ashley , since this problem also persists in Chrome itself, i dont think it would be good to rely on only Roger/GnorTech to fix it,

    since the problem then still would exist in Chrome, but may be gone in Node-Webkit.

    So if already the problem doesn't is a problem of C2 itself, then i should follow it tracks back to Chromium and file a bug report to the Chromium development team itself.

    Right?

  • SgtConti - this issue doesn't happen in Chrome, does it? I can't reproduce in Chrome here.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Ashley it did, especially in my game i worked on, it tended to happen alot when i tested the multiplayer in chrome.

    But since i now updated my chrome to 36, the issue seems to be gone.

    So as it stands it's probably a bug introduced in 34 and resolved in 36.

    Weird, im sorry if im responsible for any confusions

    So it 'happened' in chrome, but since i hadn't checked since 35, i may have missed that it has been resolved.

    I think you can close this. I hope they rebase NW soon to 36

    • Conti
  • I'm pretty sure this is a Chromium issue that is subsequently fixed, so closing. Hopefully the future updates will fully resolve this.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)