Saving project, wrong folder name check failure

  • Menu: Save as project

    Creating a new folder in the commondiag window

    Naming the folder "Hash-test", validating

    Filling the folder name field with "hash test" as name for my project (mistake, I know now that I'm reviewing each points)

    On save :

    ---------------------------
    Construct 2 Check failure
    ---------------------------
    Check failure!  This is probably a bug:
    
    Saving project to folder that does not exist
    
    Condition: FileExists(project_folder.c_str())
    File: Projects\Project.cpp
    Line: 420
    Function: void __thiscall Project::SaveToNewFolder(const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)
    Build: release 49 (32-bit) checked
    Component: Construct 2 IDE
    (Last Win32 error: 2)
    
    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way.  Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports!  Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
    ---------------------------
    Abandonner   Recommencer   Ignorer   
    ---------------------------
    

    The folder exists though. In fact the first few times I tried creating a folder and saving a project in it, to me, I had to fill the field with the name of my project (I hadn't paid enough attention to the label of the field).

    C2 r49; Windows XP; FireFox 5; ATI Radeon HD 4800

    (Switching to r50 now ^^)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Egh, this is really stupid. It's a bug in Windows. If you create a new folder, type a new name, and immediately click "OK" while the folder name edit box is still up, it returns a path to a folder called "New Folder", rather than the new name you typed in. I played with it a bit, trawled over the docs, and checked Google, but no answers. So I've "fixed" it in the next build - it just re-launches the dialog in that situation. Stupid solution but it's all I can find that works.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)