0 Favourites

[r72] Check failure - Animation Frame

  • I was trying to one sprite object with multiple images using animation frames. I tested the game a few times and it worked. I added more to the

    level and tested the game again, then it gave me an error. I restarted the editor, and it gave me this error:

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Cannot find project file for animation frame

    File: C:\Users\Nick\AppData\Local\Temp\cap78QWWY\Animations\wall_corner\Default\000.png

    This can indicate project corruption - you may be able to retry/ignore these messages and replace missing images in the project. However, please report this issue to Scirra with the steps you were doing immediately before this problem occurred.

    Condition: false

    File: Projects\AnimationFrame.cpp

    Line: 198

    Function: void __cdecl AnimationFrame::Load(const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)

    Build: release 72 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 2)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort   Retry   Ignore   

    ---------------------------

    After clicking retry, I got this error:

    ---------------------------

    Failed to load texture

    ---------------------------

    Error loading texture 'C:\Users\Nick\AppData\Local\Temp\cap78QWWY\Animations\wall_corner\Default\000.png': Failed to read image file data

    This may indicate a corrupt PNG file in the project directory. The image will not be able to be displayed in the editor.

    ---------------------------

    OK   

    ---------------------------

    After clicking OK twice, nothing looked right. The corners show up in the game, but not in the editor.

    dl.dropbox.com/u/52788071/Speed%20Ball.capx

    <font size="4">System Info:</font>

    Windows 7 Home Premium Service Pack 1

    Manufacturer: Sony Electronics Inc.

    Model: VAIO� Computer

    Processor: Intel(R) Core(TM) i3 CPU    M 330 2.13GHz 2.13 GHz

    Installed memory (RAM): 4.00 GB (3.67 GB usable)

    System type: 64-bit Operating System

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • This has been reported a lot before but we can't fix it unless we know either:

    • steps to reliably reproduce the problem, or
    • what you were doing with the "wall corner" object immediately before this happened.
  • I don't know exactly what I did. I just added a little more to the level, and then an error popped up on the preview page, I restarted Construct 2, and then another error.

    I have an idea that may help with future bug reporting: Have the editor output actions and errors into a log file.

    Is there a way to "un-corrupt" the project file (like rebuilding cache or something), or will I have to start from scratch?

  • Usually with this error, you can continue to click 'Ignore' until the project loads, then replace the missing frame.

    I've tried to load your project, but although I (think) I have the correct plugins - Extra Expressions and REx's Function - it still won't load.

    I get:

    <img src="http://dl.dropbox.com/u/34306693/loaderror.png" border="0" />

  • Opps, I forgot. I modified the Extra Expressions plugin. Here is the modified version (please do not use it for your own projects):

    dl.dropbox.com/u/52788071/ExtraExps.zip

    It will require more than just replacing the missing frame (which I already did). It just looks messed up:

    <img src="http://dl.dropbox.com/u/52788071/speed_ball_01.jpg" border="0" />

    Edit: I just discovered why it looks messed up. The origin is waaay off center. And some of the wall corner objects have a size of 20.48, 20.48 instead of 64, 64.

    Thanks for your help. If this happens again, I'll try to get more information.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
1,941 263,235
FlyingRam's avatar
FlyingRam
Unread hot topic
102 6,402
Ashley's avatar
Ashley Construct Team Founder
Unread hot topic
26 1,668
99Instances2Go's avatar
99Instances2Go