0 Favourites

[R67] Cannot find project file for animation frame

  • ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Cannot find project file for animation frame

    Condition: FileExists(GetProjectPath().c_str())

    File: Projects\AnimationFrame.cpp

    Line: 188

    Function: void __cdecl AnimationFrame::Load(const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)

    Build: release 67 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 3)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort   Retry   Ignore   

    ---------------------------

    There are no animation frames for my sprites in this game.

    All I did was add about 10 sprites, 8 events, and 12 actions then I saved my game, ran the layout and it crashed, and closed. Now whenever I try to open my game file I get the error above then Construct 2 crashes, and closes.

    Here is the .capx I was working on when it happened:

    .capx

    Mobile Intel(R) 4 Series Express

    Windows 7, 64-bit

  • I fear that you have to start to create the new project. I had the same problem and nothing worked out creation all over again and I hope that this will not happen again

  • If you have projects which no longer open send them to us and usually we can fix them (one or two things might have gone missing though).

    This bug has cropped up from time to time recently and obviously it's one we really want to fix. However nobody seems to have been able to reproduce it, and I've never seen it on my own computer. This makes it extremely difficult to fix. If you can make a backup of your project and find a sequence of steps that always breaks it, that's great - we can probably fix it immediately if anyone can get it down to that.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Thank you delgado you just helped me fix it. <img src="smileys/smiley4.gif" border="0" align="middle" />

    After reading your post the whole thought of starting over through me into a fit of nerd rage. So first I tried swearing at my computer, and that didn't work. Then I tried violently hitting the retry button a couple of hundred times, and that didn't work. So then I got real mad and swore at my computer while violently hitting the retry button, and I got this error:

    ---------------------------

    Failed to load texture

    ---------------------------

    Error loading texture 'C:\Users\User\AppData\Local\Temp\cap2T8RVY\Animations\Scope\Default\000.png': Failed to read image file data

    This may indicate a corrupt PNG file in the project directory. The image will not be able to be displayed in the editor.

    ---------------------------

    OK   

    ---------------------------

    Which let me know exactly what was wrong. So then I pressed the ok button, and reloaded that sprite in the error above.

    What happened was the sprite had been moved about 600px away from it's image point. So all I had to do then was just reset the image point, and now everything works fine. <img src="smileys/smiley4.gif" border="0" align="middle" />

    From now on I'm going to save copies as I go. But maybe this information might be useful for fixing this bug now that we know that something is causing image points to separate from there sprites.

  • Wink. My previous project had over 30 sprites and 200 events and i have problem with some animations so i cant do anything, I start a new project ;/ "error loading texture" so now i do many copies of my new project

  • delgado sorry to here that. Why don't you do like Ashley said and send it to him? I think his email is ashleyscirra.com. He said that they usually can fix them. Or just send it to my private message box here, and I will try my new nerd rage technique out on it. <img src="smileys/smiley1.gif" border="0" align="middle">

    I know I don't have your sprite graphics, or animation's but if I can find all the sprites that were separated form there image points I could just replace them with dummy sprites, and reset there image points. Then all your events would still be there. All you would have to do then is replace all the dummy sprites with the original ones.

  • Its ok i wait for more relases biuld with fixed bugs. I Post a topic, so Ashley knows the situation

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)