R61 capx crash

  • When i try to open(double click) on my capx file it crashes?

    Game

    <img src="http://dl.dropbox.com/u/22173473/R61CRASH.png" border="0">

    Any idea why this is happening?

  • This is an extra check I added to try and catch out a weird bug. It's seems to have affected your project. Did it have a check failure when running the project in r60? Send me your project and I'll fix it for you.

  • I think this one was created with R60, but the events will differ from the first capx file.

    Still has the error though.

    R60crash

    Thanks.

  • Opens and runs just fine in r61 here! Are you still having an issue with that project?

  • Opens and runs just fine in r61 here! Are you still having an issue with that project?

    Yeh...Im still having problems-

    I reported 2 errors in my last post:

    A....Underlined object combo property

    B....Could not find object's combo property index.

    I am now occasionly, getting a third error:

    C: Construct 2 game creator has encountered a problem and needs to close.....

    The errors happened after i tried to remove one of the clowns on row2 (screen images supplied) because after exporting and running the HTML.INDEX an extra set of clowns would appear on row2.

    1, Load capx....error 1 appears

    2, Click ignore...game loads

    3, Remove one of the clowns on row 2 (all rows now contain 3 clowns)

    4, Clicked export project....error 2 appears

    5, Click ignore.....export succesfull.

    6, Attempt to save capx....C2 closes with error 3

    Note..Step 3 could also be changing an event, adding a sprite..etc.

    I still get errors if I save the project before before exporting.

    Are there any steps that i can follow to self diagnose the errors...for example when errors, include line numbers?

    Thanks in advance.

    The files (including error screenshots) can be found here..

    Files

    EDIT...dont know if this connected but any editing seems to create a large number if temp files (12 meg)? here's a screenshot:

    <img src="http://dl.dropbox.com/u/22173473/Temp%20files.png" border="0">

  • Have to say, I am disappointed with responses to the errors i have reported.

    I can't create anything with it, for fear of losing stuff.

    Back to Classic for now!

    <img src="smileys/smiley19.gif" border="0" align="middle" />

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • chrisrbobs

    I found an 'undefined' entry in the 'Layout 1.xml' file. After changing this to 'None', your project opens without the error.

    If you want to try this yourself, open 'KED22 error\GAME FILES caproj\Layouts\Layout1.xml' in an editor (I use Ultraedit, but Notepad will do) and search for 'Undefined'. Change this to '(none)' and save (no quotes).

    It will look like below:

                        <properties>

                            <initial-visibility>Visible</initial-visibility>

                            <effect>(none)</effect>

                            <auto-mirrorflip>undefined</auto-mirrorflip>

                        </properties>

    As you can see, the node for <auto-mirrorflip> is undefined.

    If you don't want to go through all this, just look at the properties for your canon (Sprite3 on Layer 2) - that's the one with the 'Undefined' entry.

    Let me know how you get on.

    zen

  • zeno98

    I was getting this error on nearly project i was starting.

    Tried everything...clean installation of windows, new graphic card drivers...even swapped my hard drive(dont know why i did the last one)

    Anyway..everything working ok now (same story with the 200 backups of each project i created)<img src="smileys/smiley7.gif" border="0" align="middle" />

    Thanks for your help. <img src="smileys/smiley1.gif" border="0" align="middle" />

  • Nice to hear mate :)

    Still doesn't answer how the program would allow an invalid entry. Hopefully Ashley may have an answer.

  • r61 has additional checks to at least detect if 'undefined' is set at the moment it happens rather than when you load a project. So hopefully it either won't happen again, or will be easier to solve if it does. It's a pretty mysterious bug - "undefined" doesn't occur anywhere in C2's source code so I've no idea where it's coming from!

  • The error is usually associated with a Text objects Horizontal alignment, but sometimes a sprites Auto mirror/flip setting.

    <img src="smileys/smiley1.gif" border="0" align="middle" />

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)