0 Favourites

(R60) Deleting Objects Bug

  • I noticed if you press the Delete key on a object it will delete it and remove it from the objects list however it remains in the Object types folder in the Projects dialog.

    After objects have been deleted it can also create a crash on exiting the program that says "Object has no animations" which i guess is happening after deleting a sprite object that it can no longer find.

  • A similar thing happens to me, but the opposite; upon deleting an object, it's removed from the Projects dialog but remains in the object list when making expressions/conditions.

  • Deleting the last visible instance of an object in a layout leave the object type in the project tabs.

    This is intended. Nevertheless, the "Object has no animations" bug is a nice catch if it is indeed linked.

    I'll link this thread in the already reported bug topic so that Ashley can adress it when he's back.

    SullyTheStrange : This, on the other hand doesn't sound intended. Same, Ash will probably take a look into it when he's back.

    If you could post a capx with any information you feel relevant that would be a great help.

  • It seems rather than a bug it's some sort of object history thing then but does the object history get stored with the project? If yes it would be nice to have a clear history button or a way to disable the feature as i doubt i would use it much.

    Also i noticed if you delete with right click from the folder listings there is a confirm dialog, so there would be a additional bug in that the delete key shortcut does not also trigger a dialog.

  • I replicated the problem with a new project, with the simplest instructions ever. I added a sprite, then deleted it -- in the Objects tab on the side, it's gone, but if you go to the event sheet and start adding an event, you can see that there's three previously deleted sprites in the "Add event" box.

    db.tt/PjH7X90P

    Of course, this seems to be a little... too simple. If no one else noticed this it might just be a problem with my computer. <img src="smileys/smiley5.gif" border="0" align="middle" />

  • It's gone from the objects tab indeed, but it is still present in the project tab under the folder "Object Types".

    The object tab shows the instance present in the active layout.

    So of course, as soon as you delete the first and only instance of sprite, it is gone from the objects tab.

    I edited my previous message as I was stated the object should still appear in the objects tab once the last instance is deleted which is obviously wrong.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • ... Ohhhhhh, I understand it now. Okay okay, sorry about all that. <img src="smileys/smiley36.gif" border="0" align="middle" />

  • Due to the fact it works correctly with a right click delete on the Object types folder but leaves the objects if you press the delete key just makes it seem like a bug.

    I also don't see why you would want objects to remain still if you press the delete key shortcut on them and it's the last instance. It's sort of making using the program annoying for me because i am so used to using keyboard shortcuts and if i delete something i don't really want to do it multiple times.

    The fact it triggers a crash when the last instance of a sprite is deleted suggests there is history stored also or it doesn't correctly delete for the project. So to me it seems like a bug but if it's intended i don't really see the reason why to be honest.

  • Thanks for the report - the "object has no animations" bug has been fixed for the next build.

    The fact deleting the last instance of an object in the layout does not delete the object type is by design. You are allowed to have a sprite object with no instances in any layout, for example. To properly delete an entire object type, you must do so via the object bar or project bar.

    The issue with the delete key in the object bar was a window focus issue. IIRC, I did it because it was convenient in some cases... but I've put it back for the next build so the delete key prompts like the project bar does.

  • Thanks Ashley, i think with the bug fixed, window focus and the prompt this will be a lot nicer now. :)

  • I am not sure if the previous post means a upcoming build but i did some testing with R61 and it no longer happens for Sprite, however crashes happen for basically all other objects. <img src="smileys/smiley3.gif" border="0" align="middle" />

    The general method for a crash is:

    Add 2 text objects, Select Text2 in the layout and press the Delete key. Text2 is still in the Object types folder (shouldn't be in my opinion), select it and press Delete key and you get a crash. The same thing happens with Tiled Background and the other visual plugins.

    In fact the delete system seems buggy in general and does it with hidden objects also. If you add 2 Arrays click Array2 in the Objects tab and press delete it will crash the program. If you add a either a WebStorage, keyboard, Mouse, Browser etc then delete it from the Object types folder the program crashes.

    I am starting to think using this history feature rather than a true delete is maybe just causing the program more problems than it's worth. I don't fully get the need to have a sprite object with no instances either as couldn't you just have a hidden sprite?

    If it's going to remain it would be nice if there was a way to set a option somewhere to bypass it and just directly delete objects (Remove from the Object types folder also) when using the Delete key shortcut on the Layouts object. If the crashes/bugs get sorted it would be less of a problem but hopefully that could be possible also.

  • I followed your example exactly and it didn't crash for me. Tried it using the Text object instructions, and with others like WebStorage and it still doesn't crash.

    Have you got the very latest build ? Ashley had to do another fix on R61 and re-release it.

  • I am not sure if the previous post means a upcoming build but i did some testing with R61 and it no longer happens for Sprite, however crashes happen for basically all other objects.

    I noticed this shortly after release and issued a fix - see my comment on the r61 download. Try re-downloading and reinstalling and it should work OK.

  • I was using the previous version so i just re-downloaded and it's now working great without any crashes. Many thanks :D

    By the way this other bug you seem to have set as closed is still happening -

    http://www.scirra.com/forum/plugin-dev-bug-rendererfill_topic45082.html

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)