0 Favourites

Pathfinding Bug

  • Link to .capx file (required!):

    dl.dropbox.com/u/62939951/patherror.capx

    Steps to reproduce:

    1. using a demo pathfinding in construct open layout 1

    2. clone object type from obstacle(black) and change the color to red

    3. clone object type from sprite(green) and change the color to purple

    4. change the sprite(green) pathfinding CellSize 16 and cellBorder 0

    5. change the sprite(purple) pathfinding CellSize 14 and cellBorder 0

    6. change the sprite(purple&green)obstacle to custom

    7. open event sheet 1 add on Start of layout

    8. add obstacle(black) to sprite(green) on start of layout

    9. add obstacle(red) to sprite(purple) on start of layout

    10. add sprite(purple)find path to touch.x & y on any touch start

    11. add sprite(purple) move along path on path found

    12. duplicate layout 1

    13. add event sheet 1 to layout 2

    14. add on "N" pressed go to layout 2 on keyboard pressed

    15. run in firefox

    16. click anywhere and the pathfinding run well

    17. click the "N" on the keyboard to go to layout 2

    18. touch anywhere on right side around the obstacle and the pathfinding cant get the path but it can get the path when there is no obstacle like in the left side (the white area in left side).

    Observed result:

    This happens only in firefox and IE but not on chrome.

    Expected result:

    it's run well on all browser

    Browsers affected:

    Chrome: no

    Firefox: yes

    Internet Explorer: yes

    Operating system & service pack:

    Windows 8 Pro

    Construct 2 version:

    Release 121 (32-bit) Checked

  • help me T.T hahahhaa <img src="smileys/smiley11.gif" border="0" align="middle" />

    does anyone get the solution for this?

  • If it works in IE10 and Chrome it suggests it's a bug in Firefox. It's a difficult issue to debug, I'll see if I can get anywhere with it... if you can make a simpler example that might help too.

  • It's just work in chrome does not work in firefox and IE10.

    Ok i will try to make a simpler example tomorrow.

    Thank you Ashley.

  • this is the link to the simpler example :

    dl.dropbox.com/u/62939951/patheror2.capx

    go to the green for change layout

    just klik to the green area

  • is anyone have solution with this? <img src="smileys/smiley5.gif" border="0" align="middle" />

  • Thanks for the simpler repro, but it looks like a fairly complicated issue that may resolve to being an obscure Firefox-specific bug. We get a lot of bug reports; please allow a couple of weeks for an issue like this to be properly investigated.

  • Hi Ashley..

    thank you very much..

    I'm in the process for fixing this bug too, if I get something I'll tell you in this post..

  • Hi, still no solution with this bug?..

  • Hi,

    I've got the same problem. My game has 20 layots using (by include) the same Event sheet. When I open specific layout in Firefox pathfinding works fine. However, in the next "level" it crashes.

    My test shows that sprites are continously calculating path and can't trigger on path found. If you refresh the browser and go directly to the new "level"/layout everything is fine again.

    What is interesting, if I change destination to different one, which is not bigger than 100px pathfinding works.

    This issue is also "sometimes" present on mobile safari.

    Another test shows that if I don't use pathfinding in the "beginning" layout it works fine in the next one, but crashes in the following.

    Can it be some memory management problem in Firefox? Please help.

    regards

    Revin

  • I'm getting the same issue after updating to the latest build: 126 64 bit. Works in Chrome only. Does not work in IE 10 OR Firefox.

  • what is your last build?.. it is work on your last construct2 build?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • We're aware of the break in r126 and should have a hotfix out soon. Note however that the r126 issue is a different one to the one originally posted in this thread.

  • I'm also having trouble with pathfinding, where it won't set a cost at any time other than 'on created' and clearing the costs for an object will crash the game. Is this related or should I make a new bug report?

  • Tobye - make a new bug report. Note adding costs doesn't have any effect until you regenerate the obstacle map, but if it crashes when clearing costs you should definitely post a bug.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)