0 Favourites

Music Loop not correct.

  • Hi Team Scirra.

    I am implementing music into my project and i discovered a looping bug.

    There seems to be a gap between the loops, when a music file is played that was imported into the music folder.

    However, when the same music file is played when it is imported to the soundfx folder it loops perfectly.

    U can test it using the provided capx.

    Is it fixable?

    Capx

    Kind Regards.

    Savvy001

  • Can't reproduce in Chrome. Please always use the full bug report form - we ask for you to report your test across the three major browsers to help identify browser specific issues like this. Note the browser is responsible for seamless looping so if a particular browser does not loop seamlessly you should report it to the browser vendor.

  • Here is the bug report.

    Link to capx is in top post:

    Steps to reproduce:

    Allready done by Ashley

    Observed result:

    On my system Chrome does not loop the audio correctly if it is imported to the music folder.

    there is a gap of silence inbetween the loop of about approx 0.3 sec.

    Chrome does loop samples correctly when imported to the soundfx folder.

    Safari loops the sounds but has also a gap in between the audio loop.

    Here the gap is even bigger. about 0.5 sec

    Firefox gives the same results as safari

    Expected result:

    Infinite loop without gaps inbetween keeping the music sample constant.

    (My loops are build in cubase so they are at the propper length)

    Browsers affected:

    Chrome: yes

    Firefox: yes

    Internet Explorer: ?

    Operating system & service pack:

    Windows 7 ultimate 64 bit

    Construct 2 version:

    r122

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I've been struggling to get seamless music for a long time. Strangely, I made a song with a few seconds of silence at the end, then deleted this from the project, and added the same track without the pause with the same name, but noticed that it still wasn't seamless. I right clicked on the music in the project panel, and played one of the tracks, and it had reverted back to the deleted version with the few seconds of silence at the end.

    It's almost like it kept the other version in memory somehow.

    I just tried reimporting the same file with a different name, and it's now the correct one. How odd!

    It's working pretty well now, with only the smallest of gaps in the loop.

  • I have to second Savvy001 's fix of switching a looping file from Music Folder to Sound Folder. I had an annoying gap looping when it was imported into the Music Folder. It looped perfect after simply importing it into the Sound folder

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
378 33,276
part12studios's avatar
part12studios
Unread hot topic
302 48,099
Eric Matyas's avatar
Eric Matyas
Unread hot topic Locked topic
115 17,215
Kyatric's avatar
Kyatric Construct Team Support