0 Favourites

Memory Leak with Node-Webkit

  • Problem Description

    ____ I have built an desktop application (Quiz with animations between questions) which runs without incident in a browser, without any memory leakage, but when it's exported for Node Webkit it suddenly has a memory leak. Already checked to see if anything is causing this on my side but have found nothing. As soon as I start it up (task manager open), it starts leaking. So much so, that after a while it crashes.

    Is this a problem with Node webkit? Or have I messed up?

    Any answers or suggestions appreciated!

    Regards

    C ____

    Attach a Capx

    ____ Upload a Capx to this post ____

    Description of Capx

    ____ Concise description of what this CapX does ____

    Steps to Reproduce Bug

    • Step 1
    • Step 2
    • Step 3 etc.

    Observed Result

    ____ Memory leaks when exported for Node webkit ____

    Expected Result

    ____ No Leak ____

    Affected Browsers

    • Chrome: (NO)
    • FireFox: (NO)
    • Internet Explorer: (NO)

    Operating System and Service Pack

    ____Windows 7, Latest service pack ____

    Construct 2 Version ID

    ____ 58.2 (64bit) ____

  • Are you really still using C2 r158.2?

    If so, try at least the latest stable release r173, or even r175beta to see if the problem still exists.

    Node-Webkit has probably been updated numerous times since r158.2, so it's worth testing with a more upto date release.

  • You'll also need to upload a capx or nobody will be able to help I'm afraid

  • Thanks guys

    Updated to the latest version but unfortunately the problem persists.

    I have attached the capx file of the welcome screen. Please use discretion as it is a client project.

    Any ideas? Thanks

  • Closing, please only report issues with the latest version of Construct 2. If you are really using r158.2, then its version of node-webkit is going to be significantly older and with several known bugs that have already since been fixed.

  • Ashley

    I checked his .capx and he's using r173 stable. (!?)

  • What zenox98 said, I've updated to the latest version of Construct. Same problem persists.

  • Any ideas? Anyone?

    Thanx

  • Can't reproduce in r175 (which is using node-webkit 0.10.0-rc1) on Windows 8.1. Memory use appeared steady. Note it's normal with garbage collected languages that memory usage slowly increases, and then after some time it collects and goes back down again. That is what I observed. Perhaps you are mistaking that for a memory leak and the crash you saw was for a different reason?

  • Hey Ashley,

    Have you tried leaving it on overnight? The application currently runs on a kiosk type device and eventually crashes it. It's unfortunately not feasible to have somebody reset it every day.

    Surely the GC will start destroying objects before it uses 4gb of memory? This is how much it ends up using on the kiosk devices before the device becomes unresponsive.

    It is possible that something else is causing the crash, however, the team which is maintaining the kiosk have told us that nothing else is running on them (apart from OS related services).

  • Also, thanks for taking the time to look into it, much appreciated.

  • I am receiving feedback on this as well. I can run game in browser overnight no prob. Running it as nodewebkit build will lead to an eventual crash. Its frustrating because i cant run profiler tools / debugger on nodewebkit export which is the only place the problem is happening on. Looking at debugger in the browser/preview doesnt help because it never crashes there.

  • If it doesn't happen in Chrome, this suggests it's a node-webkit issue and not to do with Construct 2. Please report it to the node-webkit developers (https://github.com/rogerwang/node-webkit)

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Is anyone officially looking into this? Not to be a prude, but we just created a project, using the paid version of construct 2 which seems to have a problem. As a result, we're having disputes with our client. Your apathy is not doing anything to help resolve this problem with us.

    I don't buy a product from Google, why should I report it on their forum, you package node-webkit with Construct. Surely it's your job to mediate between your clients and the third party agents involved? Or are you just going to pass the buck?

    Surely you guys could show EVEN a hint of effort at resolving this problem, all I've seen from Ashley are attempts to sidestep this. It's clear that this is a problem that effects a few of your clients, paid or not, and you'd be wise to show some integrity and at least attempt to resolve it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)