Error when opening saved file and preview

  • Im not sure how to describe this problem but I think it is a bug.

    I was basicaly working on basic animated platform movement.

    After I reopened the save project,it started to work incorrectly especialy when I was writing notes...

    Removing notes doesnt fix it so there must be something else.

    <img src="http://i67.photobucket.com/albums/h314/Miu3/erroeWhenOpening.jpg" border="0">

    This shows when I open the file

    <img src="http://i67.photobucket.com/albums/h314/Miu3/errorinfirefoxTest.jpg" border="0">

    This shows when I try to preview in firefox

    File

    Sorry if it was already posted,Im still a noob in this...

  • Hello Miu, are you using r60 ? Was the project saved in r60 or a prior release (r59) ?

    Apparently, some of the frames of your animations disappeared.

    You can always click on "retry" on the check faliure window (as many times as needed untill the project opens) and check your sprite objects and load again the missing frames/textures.

    From there the JSON assertion should disappear in firefox.

  • Also: when you click on "ignore" the project keeps loading.

    From there you can see there is a missing frame in the object Player, animation "Falling".

    Load your animation(s) frame(s) in there again, and save the project, all should work again. Make sure to set the origin point correctly (it might be placed in a fantasist position after loading).

    Once the frames

    This is similar to this bug and the troubleshoot method proposed.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • This project was saved with r59 (I can tell from the project file). A bug related to this was fixed in r60. So closing as already fixed.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)