0 Favourites

Crash at Game Creation/Opening

  • Hi, today i downloaded the lastest version of construct 2, and when i try to make a project/open a existing project, construct crashes :S

    i does not think the source of the problem are my tech specs because my tech specs are:

    Intel Dual Core 2.0ghz

    3 GB Ram DDR2

    Ati Radeon HD 5450 Series (1gb vram and oc to 800 mhz), with lastest catalyst and driver update.

    Windows Vista SP2, with directx 11

    there are any radeon users here? is the video card making the trouble? or the drivers? i almost have everything up to date so, i don't know why i have this error.

  • Problem fixed, to all ati users, the v-sync it's causing problems with construct, just make a new game profile for construct 2 on catalyst control center, disable all the anti alias, opngl triple buffer etc.. and turn off v-sync. Hope it helps.

  • too bad, I have the same problem with Projects/Demos that use blending effects, but I do have a Intel Graphics Card (Latest Drivers installed, that are available for that old chip (Driver from 2009)).

    At the moment, I can only develop Games using VNC accessing to my Windows 2008 Server, that does not have a graphic card at all :)

    Can't preview the blending effects, but at least Construct2 does not crash while developing.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Crashes when opening or starting new projects are almost always graphics driver bugs. If it is a serious problem, complain to your graphics card maker, and don't buy from them again... (Intel are especially crap, and I personally will not buy any hardware using Intel graphics chips!)

  • Crashes when opening or starting new projects are almost always graphics driver bugs. If it is a serious problem, complain to your graphics card maker, and don't buy from them again... (Intel are especially crap, and I personally will not buy any hardware using Intel graphics chips!)

    In the case of ati it's not developers fault, because we are the users who are turning on the catalyst additional effects like the v-sync that cause this problem. I would suggest to put into the construct2 readme or similar some info for ati users, and nvidia users.

    I used to have a intel integrated video card too, and i ran without problems the beta of construct classic and past versions. And true the intel drivers are crap, but this because intel integrated video cards are not for gaming or for develop games, it's only part of the computer to be able to run operating systems, if these video card were not included they won't run windows vista, 7 and 8.

    Hope this info help others :)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread sticky
763 305,596
asikanddestroy's avatar
asikanddestroy
Unread hot topic
232 177,660
Tetriser's avatar
Tetriser
Unread hot topic
266 15,896
GameeApp's avatar
GameeApp