0 Favourites

Colors not showing up quite right in Chrome

  • Problem Description

    I recently built myself a new desktop and migrated all my project files over - a problem I'm having on this new computer I didn't have on the old one is that the colors on certain elements of the game are all out of whack for some reason, but only when the game is running in preview mode:

    (Actually the image compression on this makes the two images look more similar than they should, but the rainbow colors not being properly replaced with the yellow shades is the most egregious problem.)

    On the left is a running preview of the game, with the color replace filters I have on that rainbow-looking section not working properly, as well as having the saturation blown out on a bunch of the background elements. To the right is the editor, with the colors appearing how they should. This doesn't happen in Microsoft Edge, the only other browser I have on hand to test in at the moment.

    Affected Browsers

    • Chrome: YES
    • Internet Explorer: NO Operating System and Service Pack Windows 10 Pro Version 1511 OS Build 10586.494 Construct 2 Version ID Release 228
  • It doesn't happen in Node-Webkit exports either, so I'm guessing this is some kind of strange browser issue - any hints of what might be affecting it?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • This topic may be of use:

    Chrome uses a color profile to adjust the colors. Or something like that.

  • Thanks for the tip! I've done some poking around with my color management settings, but haven't really gotten anywhere super productive yet. I managed to fix the errors with the background saturation, but not the color cycling - still, at least I know where to look.

  • I fixed it! Apparently, the solution was to delete all color profiles in the Windows color management tool.

    whatever.

  • Closing as there is nothing we can do without a .capx, as per the bug report requirements.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)