0 Favourites

C2 210 Videoplayback - Chrome lag - 1fps

  • Problem Description

    Chrome Cannery for Windows 8: Videoplayback lags. Sound is fine

    Chrome for Windows 8: Videoplayback lags. Sound is fine

    Attach a Capx

    https://drive.kyberon.net/index.php/s/mI4csAIgcJc3h67 password: bugdemo

    Description of Capx

    Its just a video element which should play a predefined video after touching the "play" button. Files for mp4, ogv and webm included.

    Steps to Reproduce Bug

    Open Capx and start it

    Hit the play button (in different browsers)

    Observed Result

    Windows 8.1

    Chrome Version 44.0.2403.130 m AND Version 46.0.2475.0 canary (64-bit)

    Sound fine, Video round about 1 FPS

    Expected Result

    Video should play fine on all devices.

    Affected Browsers

    Chrome: YES

    Chrome Cannery: Yes

    Chrome on android: No

    FireFox: No

    Internet Explorer: No

    Operating System and Service Pack

    Windows 8.1

    Chrome Version 44.0.2403.130 m AND Version 46.0.2475.0 canary (64-bit)

    Construct 2 Version ID

    209 and 210

    As mentioned in the other thread, the problem moved from Android to Windows lol

    Alemar on which devices do you have the problems?

    Nomangee, does it work for you too on android now?

    Kind regards

    Patrick

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Huh, interesting - C2 tries to avoid redundantly updating the video image based on the browser's reported decoded frame count, but it seems Chrome now updates the decoded frame count in chunks instead of in real-time, making the video update very choppily. I've removed the usage of the decoded frame count and it fixes it, so should be working in the next build.

  • Wow, thank you, that was fast! Cant wait to test it

    Kind Regards

    Patrick

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)