0 Favourites

Black screen after exporting project

  • Problem Description

    ____ Blank Screen when exporting project.

    I've attempted to export the project to Kongregate and the preview only shows a black screen.

    Same issue can be seen when opening the index.html file from in a local or cloud environment

    NOTE: For a fraction of time the C2 loading screen is shown____

    Attach a Capx

    ____ See attached capx project____

    Description of Capx

    ____ Capx project is just a test project to show the problem (a single sprite visible on layout load) ____

    Steps to Reproduce Bug

    • Step 1 Export project as type "Kongregate"
    • Step 2 Upload the entire folder to an online address
    • Step 3 Point the iframe to the hosting folder into the Kongregate shell file
    • Step 4 Go trough the Upload process until "Preview" step via Kongregate () Observed Result ____ Notice that the preview is not shown at all, a black screen is shown instead ____ Expected Result ____ uploaded content should be displayed in Preview mode ____ Affected Browsers
      • Chrome: (YES)
      • FireFox: (YES)
      • Internet Explorer: (YES)

    Operating System and Service Pack

    ____ Windows 8.1 ____

    Construct 2 Version ID

    ____ Release 168 (x64)____

  • Hi there, is there any person in charge of support or having an unanswered bug forever is a feasible scenario?

    Thanks!

    Pedro.-

  • You should check your browsers console log for any errors in the script. You could try turning off webgl. Also maybe uncheck minify script when you export.

    I have no experience exporting to Kongregate these are just guesses.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • The majority of people helping out and answering questions are users just like yourself, so you're tone isn't particularly appreciated.

    Ashley has often said it may take him up to a few weeks to properly investigate a problem.

  • Well, thanks EyezWidee and zenox98 for you replies.

    I'll try turning off webgl as you suggested EyesWidee.

    Zeno (And of course Ashley), I didn't meant to be rude (Actually I wasn't), just wanted to know if the Scirra team have a support team paying attention to issues submitted by users or it is just a community supported framework.

    Let me tell you, I think Construct is a pretty good tool, but as every paid tool it should have a paid support team behind.

    Cheers,

    Pedro.-

  • Since the reproduction steps involve uploading and publishing via Kongregate, and the problem is not reported to occur anywhere else, this just sounds like a mistake during the publishing process and not a Construct 2 bug. Users commonly forget to upload some files, which breaks the game, and sometimes try to report this as a bug. Look in the browser error console for more information.

  • Hello, any solution to this problem?

    Thank you

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)