0 Favourites

audio stops playing wile looping

  • Link to .capx file (required!):

    http://

    sorry i cant reproduce capx since it is happening on a production file and it is to big and would be to much to post also i cant seem to reproduce on small projects

    link to the game is

    apps.facebook.com/jumpythefrog

    Steps to reproduce:

    1. hit the play button login with facebook

    2. pick a level

    3. start playing

    Observed result:

    after a couple of minutes the audio stops and sometimes crackles speakers

    i get this error

    Uncaught InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable.

    linking to these lines of code

    switch (this.myapi) {

              case API_HTML5:

                   this.bufferObject = new Audio();

                   if (api === API_WEBAUDIO && context["createMediaElementSource"])

                   {

                        this.bufferObject.addEventListener("canplay", function ()

                        {

                             self.mediaSourceNode = context["createMediaElementSource"](self.bufferObject);

                        Uncaught InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable.

                                            self.mediaSourceNode["connect"](self.outNode);

                        });

                   }

                   this.bufferObject.autoplay = false;     // this is only a source buffer, not an instance

                   this.bufferObject.preload = "auto";

                   this.bufferObject.src = src_;

                   break;

    Expected result:

    the looping audio to continue playing

    Browsers affected:

    Chrome: yes

    Firefox: yes

    Internet Explorer: yes

    Operating system & service pack:

    windows 7

    mac osx

    Construct 2 version:

        r146

  • eldods did you try the new beta r147? There were some fixes with the broken audio.

  • nemo i did not since i do not see any bugfix there that describes this bug happening after export

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • has anyone ran into this bug yet?

    i know im not calling stop on the audio at all it just cuts out in the middle of gameplay out of nowere at different times sometimes after 1 minute sometimes after 5

  • We need reliable steps to reproduce otherwise there is not much we can do to help. It is also strange that you marked IE affected, since it does not support the Web Audio API and the source code you referenced is only run when the Web Audio API is supported. Are you sure IE is affected?

  • 1) im not 100% on ie and what audio api am i suposed to refrence to get it to support in ie?

    2) steps to reproduce is to just play the game for longer then 5-10 minutes without leaving gameplay the audio just cuts out and stops playing most of the time its shorter then that depending on how powerful the computer is

  • why has this been moved to a closed bug the issue has not been fixed or even considered

    Ashley

    steps to reproduce are simple

    1)onstart of layout >audio> set looping

    thats it play for a while and then the audio cuts out i dont understand how you can put this into closed as it is clear as day that this is a bug in c2 audio implementation

  • eldods - please follow the bug report guidelines. If it is easy to reproduce, attach a .capx file reproducing the problem. I'd also recommend re-testing in r148 since we fixed some audio bugs already.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)