0 Favourites

[R143] Issues after updating. Maybe Or Blocks

  • Link to .capx file (required!):

    Here is my .capx

    Steps to reproduce:

    1. Run game

    Observed result:

    My game is a Match-3 puzzle game and neighboring Blocks are being spawned with the same colors.

    Expected result:

    I created a function which is supposed to go through the Blocks and ensure that when they are initially created there are no Blocks of the same color next to each other. The function seems to be running based on the debug work I've done, and was working perfectly in R139, but it is no longer working after updating to R143.

    Browsers affected:

    Chrome: yes

    Firefox: yes

    Internet Explorer: yes

    Operating system & service pack:

    Windows 7 64-Bit, Build 6.1

    Construct 2 version: R143

    So this isn't a bug I really need to explain how to reproduce. Like I said earlier the bug is an issue that's only come up after updating to the newest build. I built this game primarily in builds 132-139 and never had any issues with my "RemoveSpawnedMatches" function, the function that is supposed to prevent neighboring Blocks from being the same color. Immediately after updating though, the function just stopped working even though it still seems like it's running. I posted in the general forum about it and people suggested that it might be an issue caused by the recent bug fix applied to Or blocks. I don't know if that's what it is(partially because I don't quite understand what that bug fix meant, even after reading it), but it was suggested I post here if that was a possibility, so here I am.

  • Can you narrow this down to a specific release that broke it? (i.e. was it r140, r141, r142 or r143?)

    Can you reduce the .capx to a minimal example showing only the part that is broken/has changed?

    Your attached .capx does not appear to use OR blocks. Why does your bug report mention them?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Or blocks do not seem to be working properly for me either in the newest version (r144).

    In the Flying along game template, the game does not function properly unless I remove all 'or' blocks. For example the event "Touch|Is in touch -or- Keyboard|Space is down" does not work unless I separate it into two events: "Touch|Is in touch" and "Keyboard|Space is down".

    Edit: Oh there's a r145. Didn't get an email about it for some reason.

    Alright it seems to work fine now!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)