0 Favourites

I don't understand how to work NW.js, please help :)

  • Hi all, I recently started to use Construct 2 Personal. I've installed NW.jsforC2 and want to use it for preview. I've tried going into the Preview section of Preferences and selecting NW.js as well as pointing the Custom Browser option toward it but it doesn't do anything other than open up Chrome localhost:50000.

    Honestly, I don't know what I'm doing. I've searched the forums and Google and still gotten nowhere so here I am.

    Any help would really be appreciated, as I'd prefer to have this right before I get around to learning how to use the engine for game-making.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Have you tried setting it in your project?

    On the left panel - > Configuration Settings -> Preview browser=NW.js

  • Hi all, I recently started to use Construct 2 Personal. I've installed NW.jsforC2 and want to use it for preview. I've tried going into the Preview section of Preferences and selecting NW.js as well as pointing the Custom Browser option toward it but it doesn't do anything other than open up Chrome localhost:50000.

    Honestly, I don't know what I'm doing. I've searched the forums and Google and still gotten nowhere so here I am.

    Any help would really be appreciated, as I'd prefer to have this right before I get around to learning how to use the engine for game-making.

    Have you got the very latest stable build of C2 installed (found HERE) ?

    Have you got the very latest build of NW.js installed (found HERE) ?

    You should then only need to change the Preview browser setting, as described by dop2000.

  • Thanks guys, they're both the freshest installs and I already set it as preview browser - got nothing.

    I'm running Windows 10 Professional 64bit, r.252 64 bit of Construct 2 and NW.js from the latest link (I reinstalled everything yesterday just in case, still no joy).

  • Did you set it in C2 preferences, or in project properties?

  • You are an utter legend!

    And I'm a bit of a moron for missing that, thank you so much! It's a huge weight off my mind!

    Seriously, thanks for all of your help and patience guys, I really appreciate it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)