0 Favourites

How do I NOT use sprite shape instead of collision polygon

  • Hey all,

    i am feeling pretty stupid right now as i work with construct 2 for a while now.

    Today i encountered something strange which never happened to me before. the engine is using the sprite shape instead of the colission polygon to determine object overlapping.

    This is the code:

    here you can see the collision polygons on the left and the final detection on the right:

    Is there any option that provokes this behavior? I might have changed it by accident, but cant find it.

    Any suggestions?

    kind regards

    Patrick

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Can you do this with the spawning-sprite having a collssion mask of like 2 pixels by 2 pixels ?

    It is bit weird to make a conclusion out of wath is shown, it is drawing at the origin of a sprite with a relative big collission mask, so relative to the collission polygones its drawing at an ofset. There is also an 'average' happening.

    Also i dont see if you have a behavior on any of those sprites.

  • There where no behaviors set, just plain. i rly dont get what happened there, started a new project, did exactly the same and it worked perfectly...

    Stupid as i am i overwrote the original file...

    Working with construct for like 4 years now, never seen anything like this. Might be a strange, and very rare bug. he just used a wrong collision polygon, the drawing was just to make it clear...

    Kind regards

  • yeah.. I've noticed this too.

    Overlap seems to disregard the collision polygon and just check the square image dimensions. I figured it was just how construct2 handles it..? But it would be good if there were another condition that checks whether the polygons are overlapping.

  • Prominent normally it should just check for the collision poligon. but currently i cant reproduce this behavior anymore everthing works as intended now.

  • Hm.. yeah.. I just tryied to reproduce in a new project, but it works as intended with collision polygon.. I have experienced what you experienced though.. so I'll try to figure out what is happening..

    edit: I can't seem to figure out how to reproduce either.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)