Edit Box Problems

This forum is currently in read-only mode.
  • My Edit Box (NameEditBox Applicaiton1: Race Layout) is invisible. I have deleted it and re added it a dozen times but I still can not see it.

    If I make a new program it works fine. Can anyone tell me why NameEditBox is invisible?

    http://www.box.net/shared/9l6bxdah58

    Thanks

  • I have been fooling with this simple problem for hours now, but it just got stranger.

    While the Edit Box (NameEditBox) is on top of the Panel it is invisible, even thought I used the Order to Fount command.

    But if I move the Edit Box to the left of the panel it is visible and follows the car, even though the Attribute Center on View is not checked. NOTE if I add any new edit box to the right of the panel it follows the car. So strange.

    I need some help

  • All I know is that standard windows controls will always act strangely when placed inside DX-drawn stuff, as they're not designed to mix.

  • When you're making a HUD like that it's a good idea to make it on another layer above everything else.

    Like so:

    http://i46.tinypic.com/2qlqtyd.png

    The Edit Box you made was scrolling along with the rest of the screen because it wants to stay in the same relative position that it started in. Windows controls like that work funny. It's best to avoid them if you can. Anyway, since you had it placed outside of the viewable area you would never see it because it was always scrolling away.

    If you make a separate layer for your HUD like I showed in that pic it will work fine. Oh, and setting the scroll rate to 0% means that the HUD layer won't scroll with the rest of the layers, it will always stay in that position.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • OK I really like layers now. But I still ma having the same problem. The Edit Box (NameEditBox) is invisible in the original spot but visible if I place it far to the left ( where your diagram is.

    Even on the layer it travels with the car when I put it to the left and it is visible. Is this a bug?

    Note: I did have the Scroll off but during the last trst of taking things off and putting them back on I forgot to add that fix.

    Thanks for the info about the layers but the input box is still screwed up.

    aHum.. Commercial now for a High Score Object. LOL

  • All I know is that standard windows controls will always act strangely when placed inside DX-drawn stuff, as they're not designed to mix.

    I agree, you could call it a bug I guess.

  • Thanks for the info about the layers but the input box is still screwed up.

    Hmm. Strange.

    Well, looks like some kind of bug. That's really weird though, I could have sworn it was working fine when I tested it. You might want to add that bug to the tracker.

  • Thanks deadeye. I will also ask that they double your salary for all the help you do

  • I sent it in but here it is in a lite version

    Edit Box is invisible at original location, or if moved to the far left will tracks with the car. New added Edit Box will be have the same way.

    http://www.box.net/shared/eruyrg6khc

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)