Having a problem

  • I am trying to add movement to my enemies and using a invisible box to bound it so it wouldn't go off to the side. What my problem is, my first box works. I CTRL to duplicate it and the other boxes does not work. my enemies just pass right through it and keep going. I have enemies set up with bullet movement. I have tried to use the tutorial for platformer to set up enemies but it does the same thing. Please Help.

  • Did you make sure they all have the solid behavior?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yes I made double sure.

  • Pls include a capx

  • Ok, so Solid behavior doesn't effect it. Off, the Character can move pass it but the enemy will turn around on the right collision box and go towards the character then go off the screen passing the left collision box like it wasn't there. On, it does the same thing and the Character can't pass through it. I have the enemy set for on collision with. I have tried overlap as well.

    It's not allowing me to post links, not sure how to post the capx file.

  • Use an else instead of another condition. So do if collide with collision box > If going right, go left > Else Go right

    Just like in the basic platformer tutorial

  • I have tried that and it still doesn't do right. It hits the right and goes left. Then it just passes right through the left collision box, hits my character and goes completely off the screen. I have no idea why it does that. I Ctr to duplicate the box. It's like only the first instance (which is the right box) works and not the rest.

  • well at this point we need a CAPX or an image of your Eventsheet to offer more assistence. We would just be taking guesses as to what the problem is.

    To share a CAPX. you can upload a file to google drive or dropbox. Then copy and paste the URL. Even if there is no link we can still use the address.

  • Ok so it says I don't have permission to post URLs...

    I guess I will just type everything out then *sighs*

    This is the last thing I have tried and the enemy isn't even moving. I set the default controls to no. Am I missing something?

    SlimeEnemy > action = "right" > Simulate Platform pressing Right > Set Not Mirrored

    SlimeEnemy > action = "left" > Simulate Platform pressing Left > Set Mirrored

    SlimeEnemy > On collision with collisionbox

               > SlimeEnemy > action = "right" > set action to "left"

               > SlimeEnemy > action = "left" > set action to "right"

  • I haven't been able to figure it out yet. I feel like I either need to do 1) 12 different collision boxes or 2) Don't have jumps in the game maybe make it more of a platformer instead of a sidescroller and just have the enemies underneath or something.

    Update: Finally making progress. I think I can finally make this work

    Update 2: Finally got it~ took up setting up a boolean to get it working

  • "took up setting up a boolean to get it working"

    It shouldn't have though. Something doesn't seem right. Is there no way you can share a capx?

  • No it won't allow me to post URLs I have to have a certain amount of REP since they are trying to cut out spam or something. I can try to message it to you

  • You can still post links, just not hyperlinks. Try it without the http in the front.

  • dl.dropboxusercontent.com/u/42929721/LevelOne.capx

    lets try that

  • I can't replicate your problem. I deleted your instance variables and the collisions seem to be working fine. In any event, it looks like you have it working now.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)