Tileset problem: trash pixels and small gaps

  • Hello

    I'm having problem with tilesets. I'm using 32x32 px tilesets, everything is snapped to grid, and the size of tilesets are multiples of 32 px. It looks fine when I opened my project in construct, but when I ran the game on browser (I'm using Chrome btw) there are small gaps between tilesets.

    Here is the screenshot

    dropbox.com/s/bkg37wnihjg7hu1/Image.jpg

    Some gaps are not visible when MC is standing in certain platform, but when MC is jumping the gaps become visible again. I have searched the forum and found someone posted the same problem as mine, but I still don't find the solution. And I have tried enabling "pixel rounding" but it's still the same. Any solution for this problem?

    Thanks <img src="smileys/smiley1.gif" border="0" align="middle" />

  • in the game properties:

    set pixel rounding to ON

    set sampling to POINT

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • You need: Pixel rounding set to 'Yes', sampling set to 'Point', and fullscreen in browser set to either 'Off' or 'Letterbox integer scale'. On top of that, also avoid scaling layers or layouts to non-integer values. That's the only way to get perfect seamless display.

  • I tried your solution with pixel rounding set to 'Yes', sampling set to 'Point', and fullscreen in browser set to either 'Off' or 'Letterbox integer scale', it still has the trash pixel problem. Then I tried to set webgl to 'off', and the game looks good now.

    Thanks for the reply <img src="smileys/smiley1.gif" border="0" align="middle" />

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)