Strange message when opening my project.

  • I was wondering if anyone knows what this is. I upgraded to the latest version of C2 a while back, but I've only launched the program recently.

    What I get is a message that says the following:

    "Some files are missing from the project. They may have been deleted, or the project may be corrupt. The missing files are:

    Files\icon-16.png

    Files\icon-32.png

    Files\icon-128.png

    Files\loading-logo.png

    The project may not edit, preview or export correctly until these files are replaced."

    Notes:

    --I've never heard of these files, and I know I didn't create them.

    --Much older versions of my project don't have the problem.

    --Sometimes my project doesn't load properly when I test it in my browser, giving me a solid black screen. Refreshing the screen fixes it. I'm wondering if the problems are related.

    Any idea what this is, and how to fix it?

  • These are the construct2 logo-files , which are created as placeholders for loading screen I guess.

  • They are Construct 2 related files, basically the pictures of the scirra cog displayed on loading...

    You can open your capx with winzip or similar and add basically any pictures giving them the correct filenames, that should allow it to open up...

    looks like the files have been either deleted or corrupted probably by antivirus , CCleaner or similar...

  • Construct 2 should add these files if they are missing. If you press OK and save-as .capx, does that fix it?

  • Thanks for your reply, Ashley.

    I suspected that's how thing were supposed to work. Sadly I tried a "save as" before originally posting. I still get the same error.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • As an experiment, I uninstalled the original copy of Construct2, and reinstalled. A Construct2 folder already existed, so I installed there. Same error happens.

    Later tonight I'll delete the folder before trying again.

  • I know this is an old post, but I just got the same thing and the same missing files were not being replaced. The problem and the solution is still the same. I was surprised I didn't find much info on this when I looked it up so that is why I am posting this. Someone will need this at some time and no need to make a new post if you can give a solution in an existing one.

    They files that are missing are files used in every project so what I did was create a New Empty Project and locate the files missing in the Projects Bar. I then opened the Image Editor by clicking on the missing files and saved them into my project location. I then went back to my project and added them manually.

    I tried just finding the file location of every image but couldn't find them all, I can only assume I didn't look hard enough or some of them are being resized.

    For the files that are not in every project you can just relocate that files location and add them back in manually. I also had a sound missing.

  • I know this is old, but I just got the same thing and the same missing files were not being replaced. What I did was create a New Empty Project and locate the files missing in the Projects Bar. I then opened the Image Editor by clicking on the missing files and saved them into my project location. I then went back to my project and added them manually.

    I was surprised I didn't find much info on this when I looked it up so that is why I am posting this. Someone will need this at some time and no need to make a new post if you can give a solution in an existing one.

    Are you saving to dropbox, onedrive, or some other cloud based location?

  • No. The error was caused by me. I copied a project folder to take my project into another direction. After a while I liked how the new direction was going so I then erased the old project folder and changed the name of the newer project folder. I only assume the newer project had links associated to the old location.... You replied really fast, that surprised me. You caught my older post before I was able to edit it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)