Blank Screen when I reload

  • I uploaded a 'game' yesterday online and it seems that whenever the user tries to reload the window he gets a blank screen instead. Even in a new tab after loading once.

    So far I've tested this in Google chrome, Firefox on Os X. Works nicely on the mobile versions of those browser in android but not on the iOS.

    (I can't share the official link yet as the project has yet to be announced but I'll try and see if I can upload it to a temporary address).

    Is there a problem with the Cache loading? Is there a way I can force it to download every time it is reloaded.

    @Ashley Could you help please. I've deleted the offline.appcache yet it is still loading from cache for some reason. It works fine if you do a hard refresh.

    blueant.in/myrasfriend

  • This should be in the "How do I?" forum (which is where I usually live).

    This means that Construct failed to load one of the key project files (app.manifest, manifest,json, data.js, etc.).

    You need to use developer tools to find out which one, where the browser expects to find it, and put it there.

    As far as caching is concerned most browsers allow you to disable it.

  • gumshoe2029 Thanks for the reply.

    So, I did some researching in the console and this is what I found.

    This is how it looks when it loads for the first time.

    But after I refresh I get this white screen and I get one more error.

    Note the 'Uncaught TypeError: Failed to set the 'value' property on 'AudioParam': The provided float value is non-finite.'

    I figure its something to do with the audio files. But I can't seem to resolve it.

    It works normally if I have Cache disable on my dev tools. But even after I added the cache disable tags in my index file, it does cache for some reason.

    P.S. Sorry if this is the wrong board but I thought it had something to do with constructs working. It would be great if the mods would transfer the post to the appropriate board.

    Thanks

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • You might try adding a "Cache-Control" response header to your server (if you have control of it).

    Cache-Control: no-cache, no-store, must-revalidate
    Pragma: no-cache
    Expires: 0[/code:27qy0qpg]
    
    [url=http://stackoverflow.com/questions/49547/making-sure-a-web-page-is-not-cached-across-all-browsers]http://stackoverflow.com/questions/4954 ... l-browsers[/url]
    
    This is kind of a hack solution, and you will pay the price of having to force your users to reload your entire client each time they play your game.
    
    I am not sure how to fix audio issues yet, we are still in the mid-level development phase for our game.
  • I did add the tags but the problem is still there. I guess I should add this to the official bug list. The issue is really driving us crazy.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)