AAC gap woes / Seamless audio [FIXED]

  • I'm well aware that encoding in AAC (when importing a WAV file) will add a small gap. Definitely obvious when you're trying to create a seamless loop.

    Anyone find a work around for this? I've tried putting my music files in the sound folder. Still nothing. Tried exporting them as AAC from itunes, audacity, etc. Still adds that pesky gap. Maybe a decent m4a editor that will let me snip that bit of blank space? I'll try anything at this point. Just sick of hearing that gap when my music is looping.

  • Okay I found a way that works for me. Including it here for anyone that also finds it hard to get seamless audio files.

    -Do not convert your wav file via C2. Open it in Audacity instead.

    -Once open in Audacity, go to Effects>Repeat. This will add a 2nd version of the audio this way you can check the seam.

    -Edit the audio file down as needed to make it seamless. Once satisfactory, delete the repeat.

    -Export your audio as an AAC file and as a OGG file.

    -Import each file (should be 2) to C2 in to the sounds folder. No conversions should happen at this point since you already are supplying OGG and ACC/M4A files.

    This seemed to work best for me. Exporting to AAC via Audacity does add a small gap but C2 seems to ignore it while in the Sounds folder.

    **Note**: When you download Audacity, you also need to download the codec/plugin to export AAC files. The program will let you know if it isn't installed and provide a link.

  • good to know I haven't explored the feature much, but it seems like scheduling the audio file won't solve the problem either - is that right?

  • mudmask unsure what you mean by "scheduling audio". My audio runs through a "start of layout" condition | Play audio

  • oh whoops, it was a newer feature - https://www.scirra.com/manual/109/audio

    "Audio actions: Other

    Schedule next play

    This action causes the next Play action (all variants) to be delayed until the specified time. The delayed playback is sample-accurate. Typically events are only run every 16ms making it difficult to schedule sounds more accurately than that, but this action allows for perfectly scheduled playback, even in between ticks. If the specified time is in the past, it will play immediately. The time given must be relative to the audio hardware clock, which is returned by the CurrentTime expression, so typically sounds will be scheduled a short time ahead using an expression of the form Audio.CurrentTime + N. See the Audio scheduling example in Construct 2 for a demonstration."

    @bclikesyou

  • mudmask ah i see. worth a try i suppose?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • bclikesyou seems like it could help... but I haven't taken (or had) the time to try it out yet

  • Raising this thread from the dead!

    So I found what I consider "the best" solution (so far) to fixing the gaps at the beginning or end of audio loops.

    I recently tried out the digital audio workstation (DAW) REAPER. It's pretty sweet and made by the dude who made Winamp. First 60 days are free (all features available) and after that you would have to pay for a license. The cost is $60 which is totally worth it. Most DAW's of this caliber run $100+ easily.

    Anyways on to the fix. Upon trimming your audio and prepping it to be a loop, you would go to File>Render. When the render box pops up, you'll see under "Time Bound" a check box for "Tail". Uncheck that. It'll prevent the codec you use (mp3, wav, aiff, etc) from adding that annoying empty gap to the end of the export.

    If you find yourself having blank audio at the beginning AND end, check out the REAPER manual here and refer to section 21.5 "Rendering a finished song": it explains how to lay down markers and tell the DAW to export ONLY what is between those markers. Pretty handy.

  • I use Switch Sound File Converter and it works fine. Just make sure you only use wav files. If it loops seamlessly in the program you created it in it should convert fine as long as you keep it a wav file. I agree with you though, I stopped converting in C2 as well for that reason...

    Great tip thanks

  • ALLMarkMade Thanks for the heads up. The more solutions, the better!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)