[r154] Open URL problem with Chrome & "Wait"

  • Link to .capx file (required!):

    dl.dropboxusercontent.com/u/26714455/ChromePopup.capx

    Steps to reproduce:

    <img src="http://img5.fotos-hochladen.net/uploads/browserpopupbugoce43wfqy9.jpg" border="0" />

    Observed result:

    I have just tried to add a "Wait" before opening a link in a new browser window and noticed that Chrome opens a popupwindow without buttons (only url bar) when a Wait command is executed right before it.

    When I disable the Wait command it opens a normal browser window as expected.

    Expected result:

    Open a new browser window with all buttons, not just a small popup without default browser bars.

    Browsers affected:

    Chrome: yes

    Firefox: no

    Internet Explorer: no

    Operating system & service pack:

    Windows 7 SP1 64 Bit

    Construct 2 version:

    r154

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I noticed that you hear the sound file playing the first time without wait, but every other time you click on the sprite the sound is not played until you switch browser tabs and get focus back to the game.

  • Closing as won't fix. Browsers are really fussy about opening new windows - they want to stop sites spamming you with popup ads. As already shown the treatment is also browser-specific. If you open a window in a user input event, the browser considers it a legitimate link. However if you wait, then the window is opened "automatically" (outside a user input event) and is suspicious (it could be a spammy ad popup), so it either gets completely blocked or for some reason in this case is just treated differently. You should expect some browsers to simply block it completely, so you should not use 'Wait'.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)