[r139] Issue with adjustHSL on some PC's

  • <img src="smileys/smiley13.gif" border="0" align="middle" /> damn

  • I can reproduce, but only on export - it works fine in Firefox, Chrome and Node-Webkit in preview, but breaks on export, even with script minification disabled. I can't imagine why. In theory the exported code is identical to the preview mode, especially with minification disabled. I still can't rule out driver bugs or problems with the browser's recompilation of the shaders for security reasons... it's possible the latest drivers are still borked, especially since it seems to randomly work for some. But then I don't know why preview mode would work.

    I can reproduce on an nVidia GeForce GTX 660. What hardware does/doesn't it reproduce on?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I get the same green with red lines as sqiddster in Chrome on:

    Geforce GT 540 M / driver version: 295.73

    Win 7 64 bit

  • Ashley it doesn't reproduce on my machine, and the drivers are over 2 years old.

    Something else to think about is the fact that I created the example capx by deleting everything in a larger project - this may be significant.

  • Testing on a cheap work PC with an Intel HD integrated graphics.

    I opened the HTML link.

    In Firefox and Chrome I see the blue texture, with a single orange line in the middle.

  • I can work around this simply by setting the layer 'Transparent' property to 'No'. Does that work for you as well?

    Generally it's a bad idea to only have transparent layers, especially with 'Clear background' set to 'No' and especially in node-webkit, since it makes the background effectively undefined. In theory it should be cleared, but some graphics card drivers aren't very tidy about that and can end up garbling the display.

  • Ashley I'll try that and report back the results.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)