Can't open package.appxmanifest in VS2015

  • Im still having the same issues as Im using windows 10 and exporting to windows 10 universal.

    I fixed the problem with the ID by adding the ID in C2 "App".

    Also the Version should be something like "1.0.0.0".

    That solved some issues. So now I can preview the game in VS 2015 but cannot add this to the windows store due to app manifest problems.

    It says its still invalid.

    michael

    Did you solve the complete issue with publishing to the store or did you get as far as I did?

  • michael

    Did you solve the complete issue with publishing to the store or did you get as far as I did?

    Have not tried release to store yet, wanted to fine tune for the Windows10 Universal App release.

    Managed to build and run in vs but still having several issues:

    Can't run app via VS in full screen

    I wonder if this is still using Edge (which doesn't have full screen option) to run the app.

    Can't run Deployment Package

    When I build a deployment package for testing, and then install the app via App-AddDevPackage the install occurs without any issue, but there is no App launch icon to be found in the start menu.

    In game purchase doesn't work now

    Have not looked at this in real detail yet, but the project I am testing has already been released on Windows 8/8.1 - Just doen't work the same when built for VS2015.

    Bit short on time to look at all these new unexpected issues at present...

  • Ashley, I installed OS Windows 10 today, but I continue having the same problem.

  • For everybody having this problem:

    We continued not being able to see the manifest even with Windows 10 and after reinstalling Visual Studio all over again. Then, we saw part of my project description (as I wrote it in the Construct1 project) included quotes around a word. We removed the quotes in that text, and then finally, after many days of testing and trying, we could see the manifest.

    It would be nice if the developers of Construct could fix it, allowing us to use quotes in the description text if needed. But at least is good to know what the problem was, and maybe it will help someone else.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • paula22, glad you got it working.

    Do you have any of the issues I described in my last post?

    Thanks...

  • michael, it seems to work fine full screen to me. Not sure what running the deployment package is? I'm not using in game purchase so I can't tell about that.

  • michael, it seems to work fine full screen to me. Not sure what running the deployment package is? I'm not using in game purchase so I can't tell about that.

    paula22, interesting. When I run the game via vs there is no option to go fullscreen at all, I can max the window but there is no resize arrow to tell it to go full screen, so I get the title bar and task bar.

    As for the package: When you create your app package, you get the option to build the packages to upload to the store. If you select 'No' it builds debug packages and places them in a folder location of choice. That folder contains an Add-AppDevPackage file. So you can right click the file and choose 'run with powershell', and it installs the package (also called side-loading). Just another way to test it out without any vs overhead before uploading to the store.

  • The only issue I can reproduce is if you leave any of the project ID, version, author or description fields empty, these get left empty in package.appxmanifest and cause VS2015 to say the file is invalid. In the next beta C2 now prompts for these to be filled in if exporting for Windows 10 which should prevent this happening. I believe all other issues are either just having the wrong components of VS2015 installed, or are otherwise unrelated, so please file separate issues for those if you still have trouble and are certain you have VS2015 installed correctly and have filled out the project ID, version, author and description fields.

  • Hi, i'm having the same problem. All my project fields are filled, but i'm not sure what to use in ID, if is required a specific value or string, but anyways i filled with my company name. Please let me know if this is not right. Another thing, can someone tell me what components should be installed on VS2015, cause i have just downloaded it from microsoft and that is it. If i'm missing something, please let me know as well.

    Thanks in advance!

  • I get this error when trying to do the same thing:

    Severity Code Description Project File Line Suppression State

    Error APPX0501 Validation error. error C00CE169: App manifest validation error: The app manifest must be valid as per schema: Line 10, Column 57, Reason: '1.0' violates pattern constraint of '(0|[1-9][0-9]{0,3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5])(\.(0|[1-9][0-9]{0,3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5])){3}'. The attribute 'Version' with value '1.0' failed to parse. NewProject C:\Users\rmagie\Desktop\New project\bin\Debug\AppxManifest.xml 1

  • I figured it out guys.

    OK, two things I did that fixed this issue for me. The first one was in Visual Studios you need to change the version to 1.0.0.0 or whatever version you have on the appxmanifest file. I had mine as just 1.0 so I changed it to 1.0.0.0 , Visual Studios needs you to have a format of x.x.x.x and that fixed the first part. The 2nd part for me was the ID. You need to change the ID to com.mycompany.myapp and that should make it work. For example My id used to be 1 so I changed the ID to com.saltygamer.game Another easy way to fix this is doing it inside the project properties of construct 2 before you export. I hope this helps you.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)