Black screen in exported via cordova/xdk projects

  • Problem Description

    Black screen in exported via cordova/xdk projects since Construct release r224 and later.

    All works fine in builds r223 or earlier, and since r224 black screen started to appear instead of game.

    Tested on same equal example project.

    Attach a Capx

    https://dl.dropboxusercontent.com/u/950 ... poroj.capx

    For better investigation builded with xdk version https://dl.dropboxusercontent.com/u/950 ... st/MDZ.zip

    Description of Capx

    Just tester: simple one layer with two colored boxes that changes color on tap. No third party plugins or effects.

    Steps to Reproduce Bug

    • Export via cordova
    • Build in xdk
    • Launch on device(tested on ipad air 2, iphone 4/5)

    Observed Result

    Black screen

    Expected Result

    Game launch

    Operating System and Service Pack

    Win10

    Construct 2 Version ID

    r223-r227

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Same as me, I asked before but no one answer it seem we should back to R221.

    R227 not work with iOS

  • Same as me, I asked before but no one answer it seem we should back to R221.

    R227 not work with iOS

    Yep, we can only use r223 or older. I was think it will be fixed in non beta release r227, but its not. We need Ashley participation in this case.

  • It sounds like the same issue:

    On Cocoon this is causing a blackscreen as well.

    Can you try following steps?

    1) Serach for

    this.isWKWebView = !!(this.isiOS && this.isCordova && window.indexedDB);[/code:25s2gc75]
    
    in the c2runtime.js file and replace it with
    
    [code:25s2gc75]this.isWKWebView = !!(this.isiOS && !this.isCordova && window.indexedDB);[/code:25s2gc75]
    
    This doesn't make sense at all, but it disables the WKWebView.
    
    Regards
    Andy
  • The original report doesn't contain many details: what export options are you using exactly? Are you enabling WKWebView support or the new Intel XDK project format? (Both were introduced with r224.) Does it affect both iOS and Android or just one?

  • The original report doesn't contain many details: what export options are you using exactly? Are you enabling WKWebView support or the new Intel XDK project format? (Both were introduced with r224.) Does it affect both iOS and Android or just one?

    I tried all combinations of enabling WKWebView or/and XDK new project format. Affects only iOS version.

  • The original report doesn't contain many details: what export options are you using exactly? Are you enabling WKWebView support or the new Intel XDK project format? (Both were introduced with r224.) Does it affect both iOS and Android or just one?

    To Asheley please see this post I test many condition check/uncheck on cocoon&XDK it not work at all. (Just only iOS build)

  • Ashley any info about fix or something?

  • I can't reproduce this at all. I have now built iOS apps with the Intel XDK in the following combinations:

    Reported .capx - new XDK project format - WKWebView - unminified

    Reported .capx - new XDK project format - WKWebView - minified

    sbperftest - new XDK project format - WKWebView - unminified

    sbperftest - new XDK project format - old webview - unminified

    sbperftest - old XDK project format - old webview - unminified

    All five tests were exported with r227 and ran fine built by the Intel XDK running on an iPad Air 2 (iOS 9.3.1).

    I'm guessing it might be one of these issues:

    • are you testing on an older version of iOS? Maybe iOS 8?
    • are you re-exporting over the same XDK project? I heard there are known bugs with that - I used a fresh project each time
    • are you sure your build settings are all correct? I was testing with a newly configured certificate (it said something about being able to import an older certificate, but I couldn't build with that)
  • I also have been having the same problem with a black screen appearing after the construct splash screen though mine is only if I add the Cordova WKWebView plugins in Intel XDK when trying to enable WKWebView on ios. I have tried a whole bunch of stuff with the new Intel XDK project format enabled and disabled. I have been trying to work it out over on the Intel forums but when I came across this I decided to download the capx and like Ashley I have no problems when I export the project in the XDK project format. It works on my iPhone both with and without WKWebView.

    This leads to believe that if the Intel XDK project format adds all the necessary WKWebView plugins and settings and it definitely works (as proven above) then is there somehow a setting in Construct that can mess with Intel in regards to WKWebView? Perhaps its something if you made a project in the past and have updated Construct over time? (For instance I have been working on my project for 6 months and updated Construct as the updates have come out)

  • I can't reproduce this at all. I have now built iOS apps with the Intel XDK in the following combinations:

    Reported .capx - new XDK project format - WKWebView - unminified

    Reported .capx - new XDK project format - WKWebView - minified

    sbperftest - new XDK project format - WKWebView - unminified

    sbperftest - new XDK project format - old webview - unminified

    sbperftest - old XDK project format - old webview - unminified

    All five tests were exported with r227 and ran fine built by the Intel XDK running on an iPad Air 2 (iOS 9.3.1).

    I'm guessing it might be one of these issues:

    - are you testing on an older version of iOS? Maybe iOS 8?

    - are you re-exporting over the same XDK project? I heard there are known bugs with that - I used a fresh project each time

    - are you sure your build settings are all correct? I was testing with a newly configured certificate (it said something about being able to import an older certificate, but I couldn't build with that)

    @Ashley iOS was 8 and 9, same trouble on both. About re-exporting i always use fresh builds. Build settings is correct. As i see problem on costruct 2 side somewere in export starting from b224. Guys here have same problem as i understand with same construct builds.

  • r224 didn't have any major changes other than adding WKWebView support, and if you disable it, it should have exported an identical result to r223. So I am suspicious somehow WKWebView support is actually being enabled when you get a black screen. Then if you are missing certain Cordova plugins, it would fail to start up.

  • Hello Ashley I have the same problem when exporting to the new WKWebView format .

    A black screen Appears I am using IOS 9.0.2 Iphone 5S - Stable Release (r227)

  • Hello I recognized something weird in my project when I close the app and then open it on IOS only the first 4 layers are rendered and the rest of the layers they do not appear on the screen after the black screen issue .

  • Ashley In my project I found the problem the scml plugin is not working with the wkwebview would you like me to report it as a bug .

    Create a new project and import any spriter file then export and build with wkwebview engine on intel xdk it wont run some times a black screen appears if it was on a separate layer .

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)