0 Favourites

Game Template 4 - IAP Store Base (Templates)

  • https://www.scirra.com/store/royalty-free-game-templates/game-template-4-iap-store-base-548

    Game Template 4 - IAP Store Base — Now for sale in the Scirra Store!

    https://www.scirra.com/store/royalty-free-game-templates/game-template-4-iap-store-base-548

    <h3>Description</h3><div class="deshr"></div><p>Expand your game with a nice store and earn additional money.</p>

    Use this topic to leave comments, ask questions and talk about Game Template 4 - IAP Store Base

  • Will this work with the Amazon App Store?

  • Will this work with the Amazon App Store?

    Hi Nephi

    Sadly I guess no. Amazon has there own IAP function as far as I know.

    Regards

    AndreasR

  • will this work on both android & IOS ? using phonegap or cordova ?

  • will this work on both android & IOS ? using phonegap or cordova ?

    Hi,

    according to the plugin developer it should work on both platforms.

    But I only have test it with Android due the fact that I only have android based devices.

    But you can ask cranberrygame if the PhonegapIAP plugin supports also iOS. I think so, but just to be sure

  • miketolsa

    @AndreasR

    Phonegap IAP works on android and iOS too.

    Thanks

    Sang Ki Kwon

  • The documentation link provided in the even sheet doesn't seem to work for me.

    Do I need to do anything on my Google Play Developer Console for the IAP?

  • The documentation link provided in the even sheet doesn't seem to work for me.

    Do I need to do anything on my Google Play Developer Console for the IAP?

    I'm about to update all my Templates. Thanks for letting my know about that issue.

    Here you find the docs

    https://shatter-box.com/kb/c2-cranberrygame/

  • Hi Andreas,

    I have bought 3 templates from you (Admob + IAP, IAP Store Base and Slide In Menus).

    You did really an amazing job with those templates and they deserved every single euro I gave to buy them, they really helped me very much.

    I managed to make the ads work on the ALPHA release of my game.

    However i can not get my in-app purchases to work in my ALPHA release on google play. I followed your tutorial and studied carefully your CapX but it doesn't work for me.

    The Store Listing and Items Fetch is successful, but when my testing accounts try to make an in-app purchase, we are getting the following message "Error - Authentication is required. You need to sign into your Google Account". I have tried a lot of things to solve this but nothing works.

    What can I do to solve this and why are we getting this error message?

  • Hi Andreas,

    I have bought 3 templates from you (Admob + IAP, IAP Store Base and Slide In Menus).

    You did really an amazing job with those templates and they deserved every single euro I gave to buy them, they really helped me very much.

    I managed to make the ads work on the ALPHA release of my game.

    However i can not get my in-app purchases to work in my ALPHA release on google play. I followed your tutorial and studied carefully your CapX but it doesn't work for me.

    The Store Listing and Items Fetch is successful, but when my testing accounts try to make an in-app purchase, we are getting the following message "Error - Authentication is required. You need to sign into your Google Account". I have tried a lot of things to solve this but nothing works.

    What can I do to solve this and why are we getting this error message?

    Hi exalted

    Thank you so much I really appreciate it.

    About your issue. This is normal, because IAP only works if you download the apk file over the store. I'm not sure about the ALPHA, but it works in the BETA phase.

    So just upload your apk file as ALPHA/BETA, wait till you can see it in the store and then download it via the Google Play Store on your device.

    Then you will get following message "The publisher cannot purchase this product". Then it should work. If you want to be 100% sure add some friends as beta tester and let them download the apk as well. They should be able to purchase the perks then.

    Let me know if you have any more questions, I'm glad to help you

    Regards

    Andy

  • Hi Andreas,

    thank you for your reply

    I wish you and everyone here a happy new year!

    I have tested the apk over the store in ALPHA closed, ALPHA open, BETA closed and BETA open and my testers are still getting this message "Error - Authentication is required. You need to sign into your Google Account" when they try to make an in-app purchase.

    Before i sent you my first message i had tried it on ALPHA closed and after your reply i had the hope that it will work on BETA, but it doesn't work. I have tried almost everything and this situation is driving me crazy. I have tried it also with adding the phonegap plugin through IntelXDK and without adding it. But still the same message over and over again.

    Probably i am missing something and i have no idea what it is. But the Store Listing and Items Fetch is successful and i get the debug messages exactly as you are doing it in your template. Can you suggest anything else i should try to get it working?

  • Hi Andreas,

    thank you for your reply

    I wish you and everyone here a happy new year!

    I have tested the apk over the store in ALPHA closed, ALPHA open, BETA closed and BETA open and my testers are still getting this message "Error - Authentication is required. You need to sign into your Google Account" when they try to make an in-app purchase.

    Before i sent you my first message i had tried it on ALPHA closed and after your reply i had the hope that it will work on BETA, but it doesn't work. I have tried almost everything and this situation is driving me crazy. I have tried it also with adding the phonegap plugin through IntelXDK and without adding it. But still the same message over and over again.

    Probably i am missing something and i have no idea what it is. But the Store Listing and Items Fetch is successful and i get the debug messages exactly as you are doing it in your template. Can you suggest anything else i should try to get it working?

    Hi

    thank you, wish you a happy new year, too!

    About your issue. Did you download your game from the store then? It will not work if you copy the apk file on your phone and install it.

    You get a beta testing link for the store. When you open this link you can enroll to the beta tester group.

    Then you get a download link where you can download the game.

    This is how it works:

    1) So login into your google play developer console, select your app, go to APK and select the beta test. Then you see following screen.

    2) Then copy the marked link and open it in a new tab and enroll to the beta phase. Once you are a tester you find the download link on the same page.

    3) Download the game on your device and run it. Make sure to remove the other version first from your device.

    If you still get the error, write me a PM.

    Regards

    Andreas

  • . thanks bro your template is very good

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • . thanks bro your template is very good

    Thank your very much

  • > . thanks bro your template is very good

    >

    Thank your very much

    What this template can make can not be hacked bro

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)