0 Favourites

Need help on "build failed" Crosswalk

  • Hi, I could really need some help with this.

    When I try to build in intel xdk using the "crosswalk for android" I get this message:

    "An error occurred while building the application. Verify your build assets are correct and try again."

    I have built this app before, and it worked, but now somehow, it doesn't.

    I tried with other apps, and they worked. It's just this one

    And I don't have any different plugins for this.

    In the intel buildlog, it says:

    BUILD FAILED

    .../tools/ant/build.xml:720: The following error occurred while executing this line:

    .../tools/ant/build.xml:734: Compile failed; see the compiler error output for details.

    I would really appreciate it if someone could help me out, David

  • Hi david88eve,

    That code does look like a plugin is added, or the project name is messed up. Double check your project settings for android-crosswalk builds and also make sure you do not have plugins installed in the intel config additions file.

    Worst case, try creating a brand new app and copy the contents over

  • Thanks for the info imafett.

    Tried what you said, but it still would not build.

    Heres what I ended up doing.

    * I updated intel xdk to newest version (was on 1332)

    * Started a new project and named it something else

    * Built it successfully with crosswalk stable (forgot to change to beta)

    * Changed to crosswalk beta

    * Rebuilt, and failed (now with some other error)

    * Changed from app version 0.0.1 to 0.0.2

    * Changed from app version code 1 to 2

    * Rebuilt, and success!

    But my game runs poorly on my htc one x..

    Quick question: I've created a game with size 320x180, less than 10 objects, 60fps in chrome preview, 8% cpu in chrome preview, and 15 collision checks per tick.

    The game keeps missing collisions and runs very choppy.

    Am I missing something, or is crosswalk just that bad.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Well, you are running an almost 3 year old Android device. I have an HTC one test device and it does run pretty bad, but so does everything else on it (edit).

    Really, you can't remotely compare a desktop to that phone (quoting the 60fps n Chrome Preview). Do you have another device or an APK that I can test on. I do a lot of testing on a Galaxy S3 or Nexus 4 at work (baseline for newer phones in the last 2 years)

  • Ok, will have to update then

    Btw. Now I get this error with intel xdk:

    Buildfile: .../Blow/build.xml

    Buildfile: .../Blow/build.xml

    -set-mode-check:

    -set-release-mode:

    -release-obfuscation-check:

    [echo] proguard.config is ${proguard.config}

    -pre-build:

    -check-env:

    [checkenv] Android SDK Tools Revision 24.0.0

    [checkenv] Installed at ...

    -setup:

    [echo] Project Name: Blow

    [gettype] Project Type: Application

    -build-setup:

    [getbuildtools] Using latest Build Tools: 21.1.2

    [echo] Resolving Build Target for Blow...

    -check-env:

    [checkenv] Android SDK Tools Revision 24.0.0

    [checkenv] Installed at ...

    -setup:

    [echo] Project Name: Blow

    [gettarget] Project Target: Android 4.4.2

    [gettarget] API level: 19

    [gettype] Project Type: Application

    -pre-clean:

    clean:

    [echo] ----------

    [echo] Creating output directories if needed...

    [mkdir] Created dir: .../Blow/bin

    [mkdir] Created dir: .../Blow/bin/res

    [mkdir] Created dir: .../Blow/bin/rsObj

    [mkdir] Created dir: .../Blow/bin/rsLibs

    [mkdir] Created dir: .../Blow/gen

    [mkdir] Created dir: .../Blow/bin/classes

    [mkdir] Created dir: .../Blow/bin/dexedLibs

    [echo] ----------

    [echo] Resolving Dependencies for Blow...

    [delete] Deleting directory .../Blow/bin

    [delete] Deleting directory .../Blow/gen

    BUILD SUCCESSFUL

    Total time: 2 seconds

    [dependency] Library dependencies:

    [dependency]

    [dependency] ------------------

    [dependency] Ordered libraries:

    [dependency]

    [dependency] ------------------

    [dependency] WARNING: unable to write jarlist cache file .../Blow/bin/jarlist.cache

    -code-gen:

    [mergemanifest] Merging AndroidManifest files into one.

    [mergemanifest] Manifest merger disabled. Using project manifest only.

    BUILD FAILED

    .../tools/ant/build.xml:648: java.io.FileNotFoundException: .../Blow/bin/AndroidManifest.xml (No such file or directory)

    at java.io.FileOutputStream.open(Native Method)

    at java.io.FileOutputStream.<init>(FileOutputStream.java:221)

    at java.io.FileOutputStream.<init>(FileOutputStream.java:171)

    at com.android.sdklib.io.FileOp.copyFile(FileOp.java:206)

    at com.android.ant.ManifestMergerTask.execute(ManifestMergerTask.java:128)

    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:292)

    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

    at java.lang.reflect.Method.invoke(Method.java:606)

    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)

    at org.apache.tools.ant.Task.perform(Task.java:348)

    at org.apache.tools.ant.Target.execute(Target.java:435)

    at org.apache.tools.ant.Target.performTasks(Target.java:456)

    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1393)

    at org.apache.tools.ant.Project.executeTarget(Project.java:1364)

    at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)

    at org.apache.tools.ant.Project.executeTargets(Project.java:1248)

    at org.apache.tools.ant.Main.runBuild(Main.java:851)

    at org.apache.tools.ant.Main.startAnt(Main.java:235)

    at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)

    at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)

    Total time: 2 seconds

    .../Blow/cordova/node_modules/q/q.js:126

    throw e;

    ^

    Error code 1 for command: ant with args: release,-f,.../Blow/build.xml

    Any Ideas?

  • Figured it out. Now it was project name like you said in your first post

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
1,257 133,539
vampire6's avatar
vampire6
Unread hot topic
331 35,569
Lordshiva1948's avatar
Lordshiva1948
Unread hot topic
157 12,691
megatronx's avatar
megatronx