Pretty nice indeed.
Though there might be confusion with the already existing Pathfinder behavior, maybe have a different name to prevent confusions. (Maybe a shorter one too, like "PF" to have expressions like "Sprite.PF.Whatever" which would be even nicer).
This behavior will surely take over the old one though, it appears to work far better. Good job, looking forward to see it released.