0 Favourites

Tutorial: Platform School

This forum is currently in read-only mode.
  • [quote:1v2welc3]And I'm afraid I don't know what you mean about Lesson 5. I can move to the right just fine. Is anyone else having this problem?

    Well, it is my keyboard actually. Different keys belong to different groups and so on, and apparently, on my keyboard, pressing down right, x and z at the same time is too much which results in nothing happening.So it's not your fault, but my, and maybe some other peoples, keyboard which has limitations in the hardware.

    My real problem was that when I tried to change the keys in the applications propereties it just affected the animation, and not the movement. So when I pressed my new right key I saw the rightrunning animation, but Charlie was standing still.

    Oh, and thanks for the help with lesson 4, I got it from the Wiki.

  • Ah, I need to update the wiki. Give me a minute...

  • OK, should all be up to date now.

  • I remember the first time I saw a Construct platform game where I sent the character left and he fell off the edge of the world. I didn't know what was happening and thought it was some kind of bug.

    Maybe you can remove the leftmost wall in the first platform tutorial and instruct people to reproduce this "effect." That way everyone would know how to keep that from happening in their game.

  • I'll do one better.

    From now on, any solid wall that a game designer places outside the layout to keep objects in will be known as Stainsor's Wall.

    There, it's official.

  • YES!

    Out of a selfless generosity that is exemplary of my character I have posted a cap that includes such a wall. This cap is perfect for using as a template. Nothing needs to be changed, just build your game on top of it.

  • YES!

    Out of a selfless generosity that is exemplary of my character I have posted a cap that includes such a wall. This cap is perfect for using as a template. Nothing needs to be changed, just build your game on top of it.

    Whenever I try to run it's an error message pops up and says "There is not enough video memory to open this frame editor. Please close some other editors and try again." This wasn't happening an hour ago with my other files... and there's no process eating up the memory...

    EDIT: no cap file loading at all and Team Fortress 2 is really buggy. Must be my dying graphics card

    Hopefully all is fine once I restart.

  • This tutorial project isn't on hold, is it? I'm particularly hoping to see information on how to set up menus, cutscenes, and save games...

  • No, it's not on hold. The new tutorial should be out later today.

    As for menus, that won't be until lesson 12.

    However, cutscenes and saving won't be in this series of tutorials at all, so don't hold your breath on that.

  • Ah, pity. Okay, I'll try to muddle through...

  • Are you ready?

    And the next lesson is ready, too!

    • [url=http://www.scirra.com/phpBB3/viewtopic.php?f=8&t=2154
        Creating two more advanced custom controls for swimming and climbing ladders.

    The last one was a piece of cake. This one gets a little more complicated. There's nothing really all that new, it's just more of the same, using all the basic ideas learned from prior lessons. Just, you know, taking it to the next step, so to speak.

    Oh, and for anyone that cares, I had to redo all the previous lessons to correct a mistake (that I had no knowledge of until yesterday) so if you want to, go ahead and re-download them. It's not really necessary, though... it just has to do with renaming your controls. Short answer: Don't rename the default controls if you're using a behavior that uses controls for input.

    Also, I'll get those text files for the signs up some time soon.

  • Brilliant One thing though - the moving platform at the top of the first ladders doesn't seem to move - it goes like one pixel every 5 seconds or something. I had to wait ages before I could clear the jump.

  • Uh... what? It shouldn't, it just has Bullet behavior on it, nothing special. The speed is set to 50. It should take a couple of seconds to cross the gap, not a couple of seconds per pixel...

    It's working fine for me. And Rich and Sslaxx both tested it and said everything looked fine. Is that happening for anyone else?

  • Just tried again, it works now... probably a Construct bug

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Can't wait until the next lesson! Enemy AI should be interesting.

    How many lessons are you planning on making? Well, anyway, I find your tutorials to be really informative and the first few really helped me with my projects.

    Thank you for the superb tutorials

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
410 84,595
MrMegawatts's avatar
MrMegawatts
Unread hot topic
0 Favourites
Examples & Tutorials List
110 211,325
abdalghani's avatar
abdalghani
Unread hot topic
107 13,189
LeuNoeleeste's avatar
LeuNoeleeste