Tech Help: Side by side config error & sxstrace.exe

This forum is currently in read-only mode.
  • I am running Windows 7. I get the following error message whenever I try to run Construct:

    <img src="http://img693.imageshack.us/img693/2605/err.gif">

    I got this from the Windows Event Viewer log:

    <img src="http://img693.imageshack.us/img693/8641/detail2.gif">

    A little Googling tells me that this is an error with one of the dlls, but I can't find a guide to fixing this.

    Can someone please show to me how to use sxstrace.exe? I found the application, but whenever I run it, it just shuts down immediately.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Looks like you didn't install Construct properly. Did you install the Visual Studio 2005 redist that pops up during the setup? I can run Construct on Windows 7 just fine.

  • Yes, I installed everything. When I saw that it didn't work I uninstalled and reinstalled it again just to be sure.

    I guess I'll try one more time.

    Edit: I installed it on a different drive this time and it seems to be working now. I'm not sure what difference that makes, though. The C++ redistributable and the DirX installations told me everything was up to date.

    Well, thanks for the help. This can be locked now.

  • A little further googling yielded this gem:

    http://channel9.msdn.com/forums/TechOff/22266-Side-by-side-screwup/

    Wooops. Maybe this manifest was enabled when compiling Construct? seems like a MS screwup. Wouldn't surprise me, given how they don't bundle DX9 updates with DX10.... urgh.

    EDIT: uh... I hadn't read the whole thing. I hate these deployment nightmares. There's a lot of info in that thread, but it seems its related to linking to this or that redistributable. Perhaps the redistributable didn't install correctly? Dunno, read through the whole thing and look for clues

    EDIT2: very complete explanation and solution by codeproject: http://www.codeproject.com/KB/winsdk/sidebysideerror.aspx

  • I'm sure this would have been reported before if it was a problem in Construct's setup - as far as I know nobody else has seen this error so I think it's best to just call this a one off.

  • I also have had this exact problem. I just downloaded Construct this week, version 0.99.62, and was able to run the program fine until today, where I got the same error:

    Microsoft.VC80.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.4053"

    The only thing I had changed was a couple updates through Windows, such as an IE update, a security update, and a driver for a Microsoft mouse. I am running Windows 7 by the way. I have been trying to figure out what is wrong, and have run the sxstrace.exe and can post the results. I could sure use some help as I would love to get back to Contructing.

    Thanks. And let me know if there is any extra info you require.

  • Did you make sure you installed the Visual C++ 2005 redist during setup? The only thing I can think of is if you cancelled that, or it failed. Maybe try installing it from the Microsoft website as well.

  • Just got this error today as well on a fresh Win7 64 Install. Never had the error before until a MS Update was applied, and the error doesn't seem to be an issue unless you install that update then install construct.

  • Ergh, I think Microsoft have released another security fix to the Visual C++ runtime which is breaking things again. This is really annoying. I'll see if I can fix the setup for the next build.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)