0 Favourites

Several problems

This forum is currently in read-only mode.
  • Hello all,

    I was making this gamey thing on my laptop, and when I save it and run it on my desktop, the lighting is all screwed up! Everything is so bright. I tried deleting every object to no avail, so I can't figure out what's wrong.

    There's also the problem of not being able to traverse levels, when the box exits the screen the next layout should be accessed, but the game just shuts down. Not only that, even though I import the event sheet from the first layout, when I directly run the second layout, I can't get my objects to move! Please help me!

    Here's the cap file:

    http://www.mediafire.com/file/idyz2jhtoak/pandora.rar

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Motion blur is broken in 0.97.7 - fixed in the next build. Turn it off for now to return things to normal-looking.

    I don't know whats wrong with the other things though, I'll try to find the time to take a look soon. If you can reproduce the problems in a blank .cap with as few objects as possible, it'll be much quicker to fix.

  • If you change the transition to this:

    playerbox: Is outside layout

    System: Go to layout "level1" with transition "None" lasting 0 MS

    or this:

    playerbox: Is outside layout

    System: Go to next layout with transition "None" lasting 0 MS

    then it will go to the next layout without any problems, so it seems to be an issue with the Fade transition. I've never used the Fade transition myself, I do all of my fades manually (with single-color BG Tile objects), so you might be able to do that as a work-around for now.

    Anyway, it looks like a bug, could probably use a bug report.

  • Also, you have no Mouse & Keyboard object in your second layout. If you check the M&K object in the first layout as "Global" then you'll be able to move your box in layout 2

    Not a bad concept for a game, by the way.

  • Thanks!

    However the transition still doesn't work. And when I press R, everything goes semi transparent. Weird.

    When I shape this up a bit, I'm gonna post it on TIGS.

  • Dude! Awesome concept! I likes it! Its runs a little slow for me, but that's only b/c so many boxes.

  • It runs slow for me too, but it's because of all the fancy effects . I turned them all off and it runs pretty smooth.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)