0 Favourites

Preview is already running

This forum is currently in read-only mode.
  • I have searched the forums and bug reports, but I am unable to find any posts with this problem.

    I just started using Construct yesterday, but I keep running into this problem.

    I click "Run All" to test a program. Sometimes I get an error message telling me to run in debug mode to find the problem. Whenever this message appears, I am unable to use "Run All" again without rebooting my computer. I can run the "Debug", just not the "Run All".

    I have tried everything I know to find the running instance of the preview, but it does not appear in task manager. Restarting the program does nothing, and I am unable to open previously saved programs to see if I can preview them without a reboot.

    A reboot fixes it every time, so I know something is getting stuck in the RAM, but it is hidden.

    If anyone had this issue, or if I am just not smart enough to find the post I need, please point it out to me.

    Thanks

  • The process is usually called Temp.exe in your task manager.

    Post a cap?

  • Thank you very much, that solved my constant reboot.

    I am trying to recreate the problem for a screen capture, but so far the only thing debug has told me is:

    "Runtime Error

    A crash inside the runtime has been intercepted! The crash may be a bug in construct. Please report this to Scirra."

  • The program I am making is a small Asteroids clone, just something to help me learn the basics of Construct.

    The Debug found my problem after a few try's. I have a lot of asteroids flying around in random directions, and when they collide they set a new random angle. These random events are the cause of the preview crashing.

    The less asteroids, the less frequent the crash. If I remove all the randomizing, then it does not crash at all.

  • How to report bugs. Crashes are always bugs.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Sorry for being such a noob, when he said "cap" I thought he meant screen capture.

    I had to tear the .cap apart to nail down the bug, I will rebuild it, and submit a report.

  • there seem to be a collision bug still around in latest version, maybe try setting your collisions in the object properties to boundingbox to see if that fixes it

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)
Similar Topics Posts Views Last Post
Unread hot topic
120 23,030
CactusCartwright's avatar
CactusCartwright
Unread hot topic
0 Favourites
[plugin] Out Run
105 21,554
andreyin's avatar
andreyin
Unread hot topic
77 6,464
Kyatric's avatar
Kyatric Construct Team Support