0 Favourites

Noob questions

This forum is currently in read-only mode.
  • I'm making a roguelike, and I love the grid based movement, but can anyone tell me how to get the grid based movement to work with 8 directions using the numpad? (ie 8 moves you north, 9 moves you northeast)

    I checked the FAQ, Wiki, and forums, but couldn't find anything on the subject.

    This seems like a really fast question, is it ok if I drop all my quick questions here, or is there an IRC I should use?

    Edit: oh, and I can't seem to get my main menu working. I'm trying to make my selection arrow move up and down when I press up or down, but there don't seem to be any button input event conditions for the arrow, and the custom movement script only allows a condition for vertical movement or horizontal movement (it can't differentiate between up and down).

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • in answer to your subquestions, ask many many questions, that's the best way to learn, if you're asking 3 questions per day or something, you can make yourself a question thread, but one question a day is pretty normal for an anxious learner

    also, there's a chat link at the top of this forum for the irc

  • Ok, got a bunch of help on the chat (thank you Lucid and Shviller), the mouse and keyboard object fixed the latter problem, still taking ideas for the 8 directional grid based movement though.

  • bump. Still need help with 8-direction grid movement.

    Also, I think I may have found a bug, my menu is set to play tick.wav every time numpad 2 or numpad 8 are pressed, but it only plays the wav after the third press, the first two are silent.

    in case you're not sure what I'm talking about. (numpad 8 and numpad 2 are up and down)

    http://www.mediafire.com/?fw0xcs5h2m0liz8

    And an image of the events.

    <img src="http://i6.photobucket.com/albums/y246/Yank1234/construct.jpg">

  • Another question (though I still need an answer to the questions/bugs above).

    <img src="http://i6.photobucket.com/albums/y246/Yank1234/construct2.jpg?t=1283430876">

    Is this how you read from an INI? Running this in debug showed that Array2 still had a value of 0 at 1,0,0

    I hope I'm not being annoying, I sincerely couldn't find the answers to these questions on the wiki or in tutorials. ;p

  • Here's an example for an 8 direction grid movement:

    http://dl.dropbox.com/u/5426011/examples2/8dirGrid.cap

    made in 0.99.94

    I haven't used XAudio2 much but autoplay works fine the first time with any other wav file I've used. For a fix for that particular file throw in an event like this:

    + System: TickCount Lower than 3
    -> XAudio2: Autoplay file "C:\Documents and Settings\Rhino\My Documents\Downloads\Amaranthine\Amaranthine\Sounds\tick.wav" (No loop)[/code:3dghcu4n]
    and the tick will play the first time you hit a key.
    
    In the last problem the reason it's not working is arrays are 1 based.  (1,0,0) doesn't exist so no value is getting set,  change it to (1,1,1).
    
    -cheers
  • Here's an example for an 8 direction grid movement:

    http://dl.dropbox.com/u/5426011/examples2/8dirGrid.cap

    made in 0.99.94

    I haven't used XAudio2 much but autoplay works fine the first time with any other wav file I've used. For a fix for that particular file throw in an event like this:

    + System: TickCount Lower than 3
    -> XAudio2: Autoplay file "C:\Documents and Settings\Rhino\My Documents\Downloads\Amaranthine\Amaranthine\Sounds\tick.wav" (No loop)[/code:2zmm51yy]
    and the tick will play the first time you hit a key.
    
    In the last problem the reason it's not working is arrays are 1 based.  (1,0,0) doesn't exist so no value is getting set,  change it to (1,1,1).
    
    -cheers
    

    Wow, thanks! : D

    edit: I can't seem to get the array's 1,1,1 to appear in debug, no matter what I set the array's dimensions to, debug shows it as having 1,0,0 through 10,0,0

    edit2: I got it working just fine with an array saving as a .dat, only a temp fix though, I'd rather things like resolution be editable in the ini so players don't accidently lock themselves out with unplayable settings.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)