0 Favourites

New object crash [SOLVED]

This forum is currently in read-only mode.
  • My game start crashing if I create a new object. If I counted correctly, i have now 199 objects total, and by adding a new object, the game doesn't work anymore (not talking about instances, i'm talking about unique objects)

    <img src="http://i51.tinypic.com/t7xy08.png">

    I'm using C0.99.97 since C1 is crashing because of SpriteFont object

  • How much ram is it taking up before you add that final straw?

  • 5.21m textures

    11mb targets

    16.21mb total

    Approx 2513 MB texture memory remaining

    , says the F7 button

  • Hmm, well supposedly the only thing that should limit you is hardware, but you are getting into territory that's not been tested too much.

    I suppose it could be ram rather than vram, what with the editor taking up a bit as well.

  • I've got almost 500 objects in my game, so I doubt that's the problem. I have noticed instability with the IDE when there's 100 or more different objects in the same layout though. I think there's still a memory leak somewhere, because the IDE tends to crash in a similar fashion to the old event sheet wizard memory leak when working with animations in layouts with that many objects.

  • Btw, tried updating to CC1.2 but the bug is still there

  • Well what happens? Like is it just the game or does the editor crash as well, or are there any error messages? Also can you run the game from different layouts, or is just on the layout the object is on? Whats is the last object, and have you tried other objects?

  • ---------------------------
    Runtime error
    ---------------------------
    An unexpected error occurred and the application was terminated.
    
    You may be able to find out more information about the crash by Debugging, and attempting to reproduce the bug.[/code:1c064lbn]
    
    Then I get "Temp3.exe stopped working"
    
    [quote:1c064lbn]Also can you run the game from different layouts, or is just on the layout the object is on?
    
    The crash happens on the 3rd Layout, but doesn't matter wich layout has the last object. Like, if the crash happens, then I delete an object from Layout 3, and insert a new one on Layout 1, the crash still happens when I get to layout 3. Even if I switch the order of the Layouts, the crash still happens on the same layout (it's the one that has most of the objects btw)
    
    If I start the test right at layout 3, I get a crash
    If I start at 1 and go to 2 and then 3, crash
    If I start at 1 and go to 3, crash
    
    [quote:1c064lbn]Whats is the last object, and have you tried other objects?
    
    Tryed Sprite, INI, Text and TiledBackground and all cause the crash
  • Ok,are you using transitions?

    Then if that's not it have you ran the debugger?

    Barring any obvious signs I think your going to have to try removing objects from the 3rd layout, and then replacing them with something else. Might try the MagicCam first, and then move to the non default plugs.

  • What about creating a 4th layout, move all objects from the 3rd into it and deleting the 3rd?

    (I didn't used the layouts myself yet, so it's just an idea)

  • [quote:2468h59x]Ok,are you using transitions?

    No

    [quote:2468h59x]Then if that's not it have you ran the debugger?

    I used the debugger now, when I get to layout 3 I get this error:

    ---------------------------
    Runtime error
    ---------------------------
    A crash inside a plugin's action has been intercepted!  This may be a bug in the plugin, or a problem in Construct.  The application has exited.  Available details of the location of the problem are below (this may be approximate).
    
    Plugin: GridMovement.csx
    Object name: Movement_151_17
    Event 112 in event sheet 'Input'
    Action: 1
    Instance: 4 (of 4)
    [/code:2468h59x]
  • Well looks like something with layout 3 is interfering with your event sheet Input.

    My guess is its something to do with the attribute solid, since gridmovement is designed to avoid solids. Like if your trying to do some sort of ai with the object, and the includes telling it to go into a solid that could cause an issue.

    Might try pasting event 112 in the sheet, or a screen shot of it, and any events that might be related to it in layout 3 as well.

    In any case its a bug because of the crash, and it needs to be replicated, reported....

  • Are you using the OR condition at all in layout 3?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • [quote:211zsraf]Well looks like something with layout 3 is interfering with your event sheet Input.

    Event sheet input is only 1 event that sets the keys using the InputSystem object

    <img src="http://i54.tinypic.com/19xem8.png">

    [quote:211zsraf]Might try pasting event 112 in the sheet, or a screen shot of it, and any events that might be related to it in layout 3 as well.

    Here's line 112 of layout 3:

    <img src="http://i51.tinypic.com/2ytxrv6.png">

    "radar" is a family where all objects are sprites using grid movement (24 sprites)

    It basicaly tells it to move all the time to the left with speed 2

    If I toggle it, the error become this:

    ---------------------------
    Runtime error
    ---------------------------
    A crash inside a plugin's non-event code has been intercepted!  This may be a bug in the plugin, or a problem in Construct.  The application has exited.  Available details of the location of the problem are below (this may be approximate).
    
    Plugin: GridMovement.csx
    Object name: Movement_151_17
    Instance: 4 (of 4)
    [/code:211zsraf]
    
    [quote:211zsraf]My guess is its something to do with the attribute solid, since gridmovement is designed to avoid solids. Like if your trying to do some sort of ai with the object, and the includes telling it to go into a solid that could cause an issue.
    
    There's 1 object using Grid Movement that collides with solid, and it is controled by the player
    
    [quote:211zsraf]Are you using the OR condition at all in layout 3?
    
    Yes, I'm using it on 2 events. Deleted them but nothing changed
Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)