0 Favourites

Music/Sounds Troubles

This forum is currently in read-only mode.
  • I've run into a few problems while adding music & sounds to my game..All of the audio consists of wav files. I've never messed with separate channels so I just use "Auto play resource" and "Play music from resource".

    Anyway, to the problems. Every time I play a new song the game pauses for a bit. Not only that but when this pause happens my player falls through certain platforms. How can I get rid of this pause?

    Also, even though I add "Trigger once" to the condition that plays a new song, the event will sometimes trigger twice and have 2 of the same song play at once.

    Besides that, is there any way stop a sound while it's playing?

    Thanks!

  • are you using play song or play sound to play songs?

  • I'm using "Play music from resource" under Xaudio 2's music tab. I think the pause is due to the filesize, since the song is a .wav file, but I could be wrong. I normally use ogg but it seems ogg only works for sounds.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • to avoid falling through on pauses, limit the lower frame rate in advanced runtime properties.

  • I'm using "Play music from resource" under Xaudio 2's music tab. I think the pause is due to the filesize, since the song is a .wav file, but I could be wrong. I normally use ogg but it seems ogg only works for sounds.

    If you are using a .wav file, you could use it as a channel sound instead of music, which enables you to cache it

  • Why would you need to use a .wav for music, by the way? It's pretty simple to convert to MP3 or even OGG (although OGG is having dramas at the moment). If you're concerned about quality, you can use high rate MP3 (320kbps VBR) which seems to work quite well in my testing. During the game, having high-quality music is a bit of a waste anyway with all the sound effects mixed in.

    Just make sure your source wavs use standard frequencies:

    11025, 22050, 44100

    16 bit

    mono/stereo

    I'll put a detailed post in help/tech support in case others are having problems.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)