Having problems trying to run Construct video-related

This forum is currently in read-only mode.
  • When I start up Construct and try to create a new game, I get this error message:

    "There is not enough video memory to open this frame editor. Please close some other editors and try again."

    First thing when I click "New Direct-X Game". No idea what that's about. And secondly, when I try to open one of the old .exe files I created before, I get THIS message:

    "Construct encountered an error in the display engine:

    Failed to initilise Direct3D 9!"

    And from using the DirectX installer I have, it INSISTS there's nothing more to be updated. I'm not sure what I should be Googling to download. Just as confused about that one.

    Does anyone know exactly what's wrong, or how I can fix these problems?

  • Can you post some details on your graphics card/computer specification? I've heard that Construct is really buggy with certain graphics cards.

    Also, can you run games other people have made in Construct?

  • The GTX series is the only batch of cards I've heard people have problems with. It sounds like your card doesn't have enough VRAM - I seem to recall at least 64 or 128mb is required, I can't remember which.

    I'm not sure about this, but you also might be getting the error if you have some other application open at the same time which is using a lot of VRAM. Try quitting everything else and running construct by itself.

  • I've gotten that error on a laptop using an Intel GMA 950 (128MB shared from system RAM) when trying to have two instances of Construct open. I don't remember it doing that on a much older build, but that was a while ago.

    The 400/500 GTX series problem messes up textures and Layer previews.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Well, nevermind all that... Apparently, the problem is that... there was no video card. And I'm not using that computer anymore.

    Now I have a DIFFERENT problem, which still makes no sense. This computer DOES have a video card, and it successfully did the DirectX tests. The Direct Draw, Direct3D, and all the tests were successful. So I opened up Construct, and of course, it can create a new game. But after throwing on a sprite, a tiled background, I threw an effect onto the layer, and I got this error:

    "Construct encountered an error in the display engine. Please report this problem to the application developer.

    Failed to create Direct3D 9 device. (0x8876017c)"

    Like I said, unlike the other computer, THIS one has a video card, so it can actually create a game. That's one step. But now, a new problem, and one that makes no sense... Why is it having problems with Direct3D when I try using ANY effects? When all the Direct tests were successful? That just doesn't make sense!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)