0 Favourites

Anyone else having Python crash problem

This forum is currently in read-only mode.
  • Hello all,

    Not trying to report a bug here. Just wondering if anyone else gets the Python crash message:

    "An error occurred in python, but construct is unable to obtain any error information without StringIO.pyc"

    This happens even with the simplest of script, e.g.

    Sprite.X = 1

    I do have the python26.dll (which came with construct) in the same directory as my .cap file.

    It just seems strange that there are tutorials on wiki that show using python, and forum posts where people show examples of using it - So either I'm doing something wrong OR the latest release of Construct has somehow broken the python binding.

    If this helps: Latest version of Construct, Windows Vista32, python 2.5.1 installed on my system.

    Thanks

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • If this helps: Latest version of Construct, Windows Vista32, python 2.5.1 installed on my system.

    Thanks

    I'm pretty sure you need Python 2.6.

    Uh... I could be wrong about that . In fact I probably am. I'm not very familiar with how Python works.

  • > If this helps: Latest version of Construct, Windows Vista32, python 2.5.1 installed on my system.

    > Thanks

    >

    I'm pretty sure you need Python 2.6.

    Uh... I could be wrong about that . In fact I probably am. I'm not very familiar with how Python works.

    That could be a fix. However, that implies that end-users of my game would also need to have

    python 2.6 installed their computer to run my game executable. The wiki says that only the python2x.dll needs to be included in the same directory as the exe file for scripted games to work.

    So I don't know, I'll try upgrading my python install -see if that helps, but even if it works for me, then I'll be thinking that end-users need python installed as well. i.e. the python.dll is not enough.

  • Right, but you need Python installed to actually script with Python. I believe that .exe's built with Python only need the .dll to run, however there might be an issue if you're using other Python libraries.

    Again, I'm no expert, we should really get a Python person in here. I'm probably just spouting nonsense.

  • You are probably correct about the exe file - kind of like I need Java SDK to create java programs, but end users only need the JVM to run a java program.

    I'll upgrade my python install, and report back here, hopefully it will work and others who have the same problem will find this post helpful.

  • What version of Construct are you actually using? Have you tried the lastest unstable build? There were some python fixes in recent unstable releases.

  • The errors you are reporting makes me think you are using a version of Construct before .99.82. I got those same error messages with earlier versions. You should try again with .99.82.

  • The errors you are reporting makes me think you are using a version of Construct before .99.82. I got those same error messages with earlier versions. You should try again with .99.82.

    I have .99.62 installed which is the version that I was offered via Scirra's download page:

    http://www.scirra.com/construct/download.php

    I'll try to find 99.82 on sourceforge. Probably Scirra should change their link to point to their latest version on their download page.

  • The builds are marked as Stable and Unstable. The latest Stable builds are the ones up on the sites while the latest unstable builds are only on the forums.

  • Well ok, I upgraded to version 99.82, it seems to have fixed the crashing problem. Yay

    I'm still having another problem with the Python editor though, in that it won't save scripts to my hard drive (folder). e.g. I try to save the script as myScript.py, and when I go back to the editor and try to load the script, it isn't there. this was happening before too, but I didn't mention it earlier because the crashing problem was more important.

    Can you guys save your scripts in 99.82?

  • I cant save Python Scripts. *lol*

    Bug?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)