0 Favourites

A problem with Sprites

This forum is currently in read-only mode.
  • I am working on a game with Construct. When i try to add any sprites in my game and move them things don't go the right way. They move unexpectedly and when i delete them, Construct crashes. What is the problem? I dont know how to attach the file.

  • It might be a problem with Construct itself, like if there were any problems during the installation (did any windows pop up that seemed strange?). If that IS the case you might need to re-install or update or do whatever to Construct, to see if it can settle in your computer with more stability.

    Or it could be you're using some wonky files for sprites, though I highly doubt that. I myself use bitmaps and they work peachy.

    I've never heard of crashing due to sprite deletions though (my crashes have been kinda isolated events).

    EDIT: in fact, the big topic that says "READ THIS IF NEW" in this forum says:

    [quote:2z5yb9b2]4) If it crashes, it's a bug! Ideally, software should never crash. A crash indicates the program has failed, not the user. In this case, post a bug report.

    As far as the "unexpected movement" thing, you'd have to be more specific, because there's no way to gauge what you mean by that vague statement. If you know how to post a .CAP, that might help (I don't personally), so one of the pros can look at what's going on.

  • I meant that when i try to move it, it goes further than i want and the points around it disappear. I am using the stable 0.99.6 Construct version.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Sounds pretty weird. Like I said, though, you might want to post a link to your .CAP file so folks can take a good look at whatcher doin'.

    To me, it sounds like you overlooked some simple stuff that is making things all buggy, but I wouldn't know.

  • Sounds like you checked "snap-to moving." Could be wrong though. .Cap couldn't hurt.

  • where is that "snap-to moving" button???

  • Have a look at your zoom level, I know I have some weird movement from sprites if the zoom level is not 100%

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)