0 Favourites

[HELP] Effects for Families

This forum is currently in read-only mode.
  • Hey.. Need some help with effects for families.. hope some1 can help me..

    I'm using the advanced Filter effect in some Sprites, they are all inside a family and i'm trying to change the 'red', 'green', 'blue' color of them with events.. but if I go into action, select the family, go into the advanced filter tab and select 'red', there is no parameter available.. only if into the action I select a sprite instead of the family.. So I was trying to do that with script but I have no idea how.. any ideas?

  • up..help

    if some1 didn't understand what i'm trying explain, I can try making more clear

  • Right click the filter color, select "use expression" and use rgb(r, g, b).

  • Right click the filter color, select "use expression" and use rgb(r, g, b).

    but there are no parameters for changing the 'r g b' of a family

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Yeah there are a few effects that don't have parameters when trying to use them with families. It's really annoying. I've resorted to giving a family object multiple versions of an effect with different parameters to work around this, but it really sucks. Does this have something to do with Construct or the creators of the effects?

  • If the parameters are there normally, but not with families, then it's construct, not the effect.

  • I know this is an old topic, but I've run into the same issue and managed to sort-of find a workaround...

    To make the Effect parameters appear, first create the Action using a Family member instead of the Family. Then, after the Action is created, modify it and replace the Family member with the actual Family. The parameters will not disappear.

  • Great find, thanks Funky.

  • Looks like the workaround I posted does not work every time... Seems to be rather random. If you keep switching Families and Family members around, it will eventually allow you to set parameters, however "eventually" can be the next switch or a very long time.

    Also on opening the .cap again, the Effect parameters will not be visible in the Event View - the Action will simply say "ObjectName:", copying and pasting it will result in the copy having the proper text, like "ObjectName:SetParameterToWhatever".

    I'll post under the R2 release thread in Discussion... Perhaps someone involved with coding will chime in - I've looked throught the Effect shader files and the issue seems to lie in Construct.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)