0 Favourites

Modifed platform plugin causing custom animation buggyness

This forum is currently in read-only mode.
  • So far using the built in platform plugin I found it to be very usful, that was until I started to add ladders, I was able to get the correct animations working for the player but, the jump bugged out using the built in tags this worked fine but broke the ladders, so I took a look into the platform code to suppress playing of the ladder animation, so far it was as simple as going to ExtObject::OnFrame and to line 1250 adding the following in place of the single call(also added a set and unset flag what simply does a bitwise operation to enable and disable the altered behavior) :

    if (ExtendedFlags & MT_ExtraFlags::EX_FLAG_ONLADDER) { }
    else { SetAnimation(jumping); }
    [/code:3n3uuwid]
    
    for the sake of all this all MT_ExtraFlags::EX_FLAG_ONLADDER means is 0x01
    
    But now I get a weird bug what did not occur where if i drop down off a platform or jump onto a ladder instead of climbing from the floor when i climb up the animation frames will not increment I also get the same effect doing this check from within the is jumping condition.
    
    Edit: Manged to fix the bug, it was not related to the plugin but rather the event sheet(On dropping from a platform and midair attach I forgot to set the plugins ladder flag but had set the OnLadder private var I was using).
  • mathew653

    So far using the built in platform plugin I found it to be very usful, that was until I started to add ladders, I was able to get the correct animations working for the player but, the jump bugged out using the built in tags this worked fine but broke the ladders, so I took a look into the platform code to suppress playing of the ladder animation, so far it was as simple as going to ExtObject::OnFrame and to line 1250 adding the following in place of the single call(also added a set and unset flag what simply does a bitwise operation to enable and disable the altered behavior) :

    > if (ExtendedFlags & MT_ExtraFlags::EX_FLAG_ONLADDER) { }
    else { SetAnimation(jumping); }
    [/code:1909knfp]
    
    for the sake of all this all MT_ExtraFlags::EX_FLAG_ONLADDER means is 0x01
    
    But now I get a weird bug what did not occur where if i drop down off a platform or jump onto a ladder instead of climbing from the floor when i climb up the animation frames will not increment I also get the same effect doing this check from within the is jumping condition.
    

    This is posted in the - now retired - Construct Classic section.

    Is this what you intended?

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • This is posted in the - now retired - Construct Classic section.

    Is this what you intended?

    Yea, the plugin work is related to construct classic's engine.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)