0 Favourites

Cant get collision mask to work

This forum is currently in read-only mode.
  • I have my character with platform behavior with a collision mask set up. For some reason whenever he collides with something, instead of it colliding with the mask, it collides with the whole sprite.

    I have a test set up with my character standing and a block coming at him. It's supposed to collide with him around his shoulders but it collides with the gun.

    Also how am I supposed to include .cap file when I don't have permission to put url's

    For anyone who reads this the link to my .cap file is a couple posts below.

  • Is the mask set for every frame of the sprite?

    You can bypass the url limitation by putting extra characters in it like http*://

  • The sprite I am testing it with is just a stationary sprite with a mask. I went in the editor clicked on the mask button drew a red square in the part I wanted the mask and erased everything else. My character has platform behavior and is set to per pixel collision. the block I put is set to solid and is set to bounding box collision "also checked it with per pixel to" and it still doesn't seem to be working.

    I tried adding extra characters to the url but it says I don't have permission to post plain text url's.

    I understand it is to prevent spam, but it is kind of counter intuitive to put a guideline saying to post .cap files but restrict it for new users.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • They used to have a way to attach the .capx when posting but that option is gone for some reason. Try sending it to me via pm

  • Tried sending it via pm but it says I need 500 rep to pm someone.

  • You can email it to me then: -removed afterwards-

    Here's his link:

    Wait so this is Construct Classic, I don't remember CC having collision masks... Anyway, sorry, I didn't notice this was in the CC discussion area, so I can't really help

  • That's alright.

    Thanks for posting my .cap file link, hopefully someone can use it to help.

    Thank you.

  • bump

  • I haven't had a chance to look at your file, but if the collision mask is setup for each frame as you say, then check in the sprite's properties to make sure collisions are set to per-pixel instead of bounding box. If it's still colliding with everything then make sure the areas of the mask have an opacity of 0.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)